Strange string in article with more than one author

Hello, I am new to OJS and I am using OJS 3.1.2, I would like to know what I am doing wrong that every time I publish an article with more than one author between the two names I get this string
“## common.commaListSeparator ##” (without the quotes).
It shows me like this:
Name Author 1 ## common.commaListSeparator ## Name Author 2

regards

Hi @yusmelvis,

The strange string you see means that the translation for that string is not available. I guess you are not using English UI.
To add the missing localisation string I suggest to use translator plugin. It is easy to use.

Regards, Primož

Hello Primož,

Thanks for answering me. Actually I am using Spanish UI. Could you explain me better how to use that plugin? is that I am new…

Thank you

Hi @yusmelvis,

First install Translator plugin:

  • Settings - Webside
  • Plugins - Plugin Gallery
  • Translator plugin - Install

Use the plugin and add missing translation:

  • Setings - Webside
  • new menu item: Translate
  • select es_ES language and edit
  • find lib/pkp/locale/sl_SI/common.xml and Edit
  • find common.commaListSeparator
  • clik on it and add missing translation
  • Save on the bottom

That should be it.

Regards, Primož

2 Likes

Thank you!! @Primož I followed your steps and everything worked correctly. Thanks again!!

Regards, Yusmelvis

This just saved my day. Thanks a lot! :+1:

thanks to your explanation, I could solved the issue

Thanks @primozs, it was very helpful for me!! :smiley:

You can download and install (unzip) the last es_ES translation here:
https://revistes.uab.cat/web/sites/default/files/documents/es_es-v02_0.zip

For OJS 3.2 (january) we plan to use weblate that will let us have es_ES and ca_ES up to date.

Hi,
I have the same problem with Polish language. I have installed the Translator plugin but I can’t find the “translate” menu in Settings–> Website.

can you help me?
Regards,
Dorota

Hi @doridek,

We have converted our translations from XML format into PO format, which is a standard used by many translation tools. We’re about to launch a new translation toolset that uses this, so I wouldn’t recommend working on translations using the old Translator plugin. If you’re interested in taking an early look at this, please send me a private message!

Regards,
Alec Smecher
Public Knowledge Project Team

Dear Alec,

I am following on this because I am in the same situation as Dorota: I need to translate some strings, which at the moment appear as ##…## in several parts of the website, but I cannot find the “Translator” menu in “Website > Settings”. I have read your message about the new format you plan to use for translation (PO), and I would also like to keep informed about that.
However, in the mean time, how can I advance with this issue? Is it still possible to use the old plugin?
Best regards
Leonardo

Hi @leonardo.mancini,

It is possible, but you need to install the translation plugin via the plugin gallery.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

thanks for your answer. I have installed the plugin; however, as per the situation Dorota was describing, I cannot find the “Translator” menu in “Website > Settings”. I also attach here a screenshot. Do you know if I am missing something?
Best regards
Leonardo

I have found it! I had to enable it first again under “Plugin”.
Thanks again.

1 Like

Tahnk you @leonardo.mancini!

That also resolved my problem! :slight_smile:

@asmecher I am interested in the new format you plan to use for translation (PO), and I would also like to keep informed about that. :+1:

Thank you!
Dorota

Hi @doridek,

If you want to try working with the new tools, just let me know via PM – I’ll set you up!

Regards,
Alec Smecher
Public Knowledge Project Team

Hi there, I am glad this helped also you Dorota.
Alec I will also write you via PM for the new translation tool!
All the best,
Leonardo

1 Like