Reset password problem 2 emails

Hi guys, I have a problem with password resetting.

If I click on “Forgot your password?” I immediately get 2 emails:

  • 1° Password Reset → with new credential
  • 2° Password Reset Confirmation → with a link to reset (but if I click on it, it say that is not valid anymore)

So, I have a person that is getting continuously reset password email, without asking them. And every time he get new credential, he need to change the password, and this is pretty annoying, he cannot use the website.

Now the two questions:

  1. is it a bug that is getting many reset password emails or is just someone making fun of him?
  2. how can I set these emails correctly? I need the second email “Password Reset → with new credential” only if I click on the reset link that I have in “Password Reset Confirmation” email.

What I have to do to make it possible?
Many thanks in advance.

My settings:
OJS Current version:
PHP version 7.4.21

Best regards,

My research continue…
I found this post:

but no solutions… (I tried, I click only once, i get 2 emails, with the link already expired) I also clear the journal data cache and browser cookies, nothing changed.

Hi Pau,

We’re also getting reports of this happening and I think it might relate to email clients “pre-scanning” all the links inside the email body. What sort of email client are you using? Does the problem happen if you try a different email / client?

Hi Bart, thanks for your answer.
As SMTP server my company is using

Is kind of mixing 2 different ways to reset you password, no? Is not simply possible to set on one method and set off the other one?

Hi Pau, just to clarify I meant what program is the user using to read the sent emails? It’s the program that might be accessing the password reset link before the user does, thereby rendering it expired.

1 Like

Hi everyone,
just to let you know we solved the problem.
Was @bart suggestion to help me - so was our system - checking all the links in the emails - was giving us the problem. Just disabling this option, solved the problem.
Many thanks for your help!