Mix with authors, co-authors and translators


#1

Hi,

I’m using OJS3.
When an article has translators, what is common here in Brazil, it is shown in the list of authors and co-authors although it is not one of them.
For us there should be a clear separation between authors, co-authors and translators. Mostly translators.
Is there any way to make it quite clear that the translator is not an author?

Regards,

Tarcisio Pereira


#2

Hi,

Any response?

Regards,
Tarcisio Pereira.


#3

Hi

The translator also appears in the citation plugin. It should only appear the authors.
Crossref xml also puts the translator as author.

Rergards,
Tarcisio Pereira.


#4

Also related: https://github.com/pkp/pkp-lib/issues/3962

A proposal for normalizing the taxonomy of contributor roles: https://github.com/pkp/pkp-lib/issues/857


#5

Note that translators are separated with a semicolon, authors with a comma. But I agree that it should be more transparent for readers.


#6

The distinction between semicolon and comma is based on OJS’s “user groups” and the structure of the Submission::getAuthorNames() function:

When listing “author” (contributor?) names, when the user group (contributor role?) changes, we add a “semicolon” (or whatever the overrides the semicolon); when operating within the user group, we add a “comma” (or whatever overrides the comma).


#7

Note that if you check the option “Show role title in contributor list” in Users & Roles -> Roles -> Translator -> Edit, this adds the text “(Translator)” (or translation) to the the Article view and to the DC.Creator.PersonalName in the metadata. The CrossRef export and Citation Plugin remains in error.