We installed a OJS 3.0.2 and everything worked fine.

But recently, a user is getting this message after login (she using the right username and password)

If I (the administrator) login as her, I can see everything fine and we have also tried this with a different browser a different computer with a different OS and so on on her end (she even tried a logging in from a different network (using Lynx inside an ssh shell). Nothing works, she keeps getting the same error message.
Is it possible that there’s something with the instalation?

Hi @Lanko_Marusic,

You should explain a bit more what exactly you (user) are doing - which steps and where errors happen.

But looking in your URL of the OJS: it looks like you have an empty OJS, no content, just base installation. I would suggest to reinstall the latest version. It is always better to use the latest, if you can.

Regards, Primož

Hi all,

I am the user that is having the problem. Here’s what I am doing.

While logged in, I go to:

  1. Click on “Copyediting” (current status of the submission). I get an “Access denied” pop-up.
  2. I click “OK” on that, and get the following:
    “You do not currently have sufficient privileges to view the submission. Please edit your profile to ensure that you have been granted the appropriate roles under “Register As”.”
  3. I click "OK on that, and get an “undefined” pop-up.

I then click on my user name in the corner to view my profile. The site logs me out (even though I clicked on “keep me logged in”). I log back in.

I click on the “Roles” tab and get ##user.authentication.userRequired##. Actually, this pops up on every tab–it won’t let me view any tabs that I click on. (Interestingly, the tab displayed by default, Identity, is visible, but it disappears if I try to view another tab and then try to click on Identity).

Additional information: I am on Linux Mint, everything up to date, and have verified that this happens in Firefox and in Chrome (the latter is my unmodified browser). I also got this error on an iPad with Safari.

It might be relevant that I am on a slow-ish/high latency satellite connection? FWIW, I was able to set up an account and submit a paper from a different location in the US back in February, and everything seemed to work back then.

I can’t log in from a different location where I am. But let me know what else you need–I can give you more information from the console output.

ETA: actually, when I looked at the site in lynx, I never got to a point where I got any error messages–the relevant portion of the site doesn’t render in a text browser. So I cannot verify whether it’s my location that’s causing the problem. (But in any case, if it is the location, there’s a bug somewhere.)

I got the same error ##user.authentication.userRequired## by changing the configuration parameter to Off as below works!

; This check will invalidate a session if the user’s IP address changes.
; Enabling this option provides some amount of additional security, but may
; cause problems for users behind a proxy farm (e.g., AOL).
session_check_ip = Off

Further great explanation go here What is "session_check_ip"?


Thank you @dung
It’s solved my Problem

in Additiion i change my Session cookie name in