Tinymce toolbar does not appear on /manager/setup OJS 2.4.6

On manager setup is displayed only textArea without tinymce toolbar. Some suggestions?

Hi @ophi_ro,

Are you sure your TinyMCE plugin is correctly installed? You can check if it’s listed on the generic plugins page, under management, and also check if it has an entry into the versions table, using this sql:

SELECT * FROM versions WHERE product = 'tinymce';

If you don’t have a versions entry for this plugin, you can run

php tools/upgrade.php upgrade

Make sure that you have a database backup. Also make sure that no file is missing inside your plugins/generic/tinymce folder. You can do that by copying the original files from the 2.4.6 tarball for this folder.


Hi Bruno,
All requirements are met:
-tinyMCE is enabled
-and all the files are in plugins/generic/tinymce folder.
I cleaned cache folders (with ftp) and also clean data caches, clean template cache (from admin page).
Nothing changed …

The plugin worked for a while but after I set disable_path_info=off (was on), has stopped function.



That’s the only thing you’ve changed? I tested here with both path info on and off and it’s working ok.

I also see a syntax error: unexpected token < at the console. Not sure from where it is coming from, but is there any chance you’ve changed the tinymce js files?

Can you also check your php error log for any errors?


I’m set display_errors = On - no php error related to tinymce.
unexpected token < refers first line tiny_mce_gzip.php (I think), baseURL is correct but when it tries tinyMCE.init it crached (my opinion)

<script language="javascript" type="text/javascript">
					entity_encoding : "raw",
					plugins : "paste,jbimages,fullscreen",
					mode : "exact",
					language : "en",
					elements : "mailingAddress,contactMailingAddress,publisherNote,sponsorNote,contributorNote,history",
					relative_urls : false,
					forced_root_block : false,
					paste_auto_cleanup_on_paste : true,
					apply_source_formatting : false,
					theme : "advanced",
					theme_advanced_buttons1 : "cut,copy,paste,|,bold,italic,underline,bullist,numlist,|,link,unlink,help,code,fullscreen,jbimages",
					theme_advanced_buttons2 : "",
					theme_advanced_buttons3 : ""

I recopied today all files from ojs kit but nothing …
The only errors that I’ve seen are the ones on the first screen


Sorry the long wait. What’s your site url? I can try to debug it since it seems a JS problem.


Hi Bruno,
site is http://anale.fssp.uaic.ro/
Interesting is that the only place I’ve seen toolbar tinyMCE working is Custom Block Plugin.
I also copied the entire site on localhost and all workink ok there.
I could display_errors = On if it would be helpful.
Thank you

Ok, I think that the custom block plugin is working because inside the plugins management page it doesn’t make any difference if the plugin has a correct entry inside the versions table. That’s why the tinyMCE plugin is loading there.

But outside it is not loading and you have the error. I am not sure why, because you did confirmed that the entry is there, and it seems it has the correct values.

I will take a look at your site, thanks.

I have the same problem in OJS and OMP, occurred when changing server. In this new server, the site has been hosted as a subdomain in a directory. Any solution available?
Thank you

Hi @Adan_Salinas_Araya,

See e.g. this post:

Alec Smecher
Public Knowledge Project Team

Thanks I try.
Regards Adán

Thanks problem solved. I removed the .gz file in the directory \lib\pkp\lib\tinymce\jscripts\tiny_mce
and then delete all the cache site .

I have the same problem and the solution is access menu User Home > Site Administrator > Administrative Function: click Clear Data Caches. Then press Ctrl + F5 button on your browser.

Hello All,
I have the same problem in OJS where plugin tinyMCE does not appear. I have try from above suggestion but the results is nothing.

Would you like to help me…?

This is my OJS website http://ejournal.mkduncen.ac.id
You can see for quick at register page.