[Solved] Questions about OJS 3.0.2

Hi all,

I suspect there’s an error message, either in your browser console or your PHP error log, that will provide some more details on the problem.

Regards,
Alec Smecher
Public Knowledge Project Team

If u can guide me how to get this log, i can gather it for you.

Hi @Hugo_Melo,

See the FAQ for information about your PHP error log; for the browser console, Google your browser name and “error console” for instructions on how to find it.

Regards,
Alec Smecher
Public Knowledge Project Team

Ok, here is what the chrome console is giving me when i choose a template with those variables:

image

1 Like

Hi @Hugo_Melo,

Thanks, that’s helpful. I’ve filed this for attention at Resolve JS console warning · Issue #2863 · pkp/pkp-lib · GitHub.

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like

I am having a problem I haven’t notice before.
When setting a reviewer to judge a paper, the deadline is completly wrong, even when its set correctly: Look:
image
image

Somehow, i think its related to the time settings on the config.php, but i have no clue how to fix it.
My config.php is this:

; Short and long date formats
date_format_trunc = “%d-%m”
date_format_short = “%d-%m-%Y”
date_format_long = “%B %e, %Y”
datetime_format_short = “%d-%m-%Y %I:%M %p”
datetime_format_long = “%B %e, %Y - %I:%M %p”
time_format = “%I:%M %p”

I don’t think the problem is in the server clock since the time is correctly showed on everywhere else:
image

Any ideas?

Hi @Hugo_Melo,

I believe this is already filed at Changing date formats in config.inc.php can lead to misparsed dates · Issue #2689 · pkp/pkp-lib · GitHub. I’ll link to your description from the bug entry.

Regards,
Alec Smecher
Public Knowledge Project Team

According to the issue, if i turn my config.php back to original the problem will not happen?

Hi @Hugo_Melo,

You can try that and see if it changes the behavior. However, I’ve just tried with OJS 3.1.0 and your date format setting and wasn’t able to reproduce the problem. The most helpful thing would be to…

Regards,
Alec Smecher
Public Knowledge Project Team

Okay. Getting the time in config.php back to original turned off the error.

image

I will now update do 3.1 and change time to Brazilian again and see if the error is back, and report here for you.
Thanks for the patience.

Hi @Hugo_Melo,

One of our developers has put together a patch for the Javascript issue you described earlier. Could you test this change and report back whether or not it corrects the issue?

Regards,
Alec Smecher
Public Knowledge Project Team

Alright, I am about to try this, but i need more info.
For example, in what file should i put this code? At what position?
I am already at OJS 3.1, should I try this piece of code? I am waiting for receiving any article for evaluation to test if the error still in ojs 3.1.

Hi @Hugo_Melo,

The best way to apply the change is using the standard “patch” tool. You can read more about patch files e.g. here: What is the format of a patch file? - Stack Overflow

Regards,
Alec Smecher
Public Knowledge Project Team

Man, i’ve read it several times, but I think it is too much for my experties.
I couldn’t figure out how to “patch” that piece of code.
I will test the same error in 3.1 to see if it continues though, and let you know.

Hi @Hugo_Melo,

In brief, edit lib/pkp/js/classes/TinyMCEHelper.js; find the lines that the patch describes starting with a - and remove them; and add in their place the lines the patch describes with a +. (Omit the - and +, of course.)

Note that you’ll nave to turn off minification in your config.inc.php for these files to be used instead, and you’ll need to reload in your browser.

Regards,
Alec Smecher
Public Knowledge Project Team

OKay. I am here to show you that the error persists in 3.1, and it is even worse, the date is now empty:

image

image

I will try to insert the code and let you guys know about it.

However, i am having a more annoying trouble now. The email models i have made to notify authors, isn’t showing anymore. Tried to delete and create it again, but still not showing, and interesting it always create as a Signture Manager, what didn’t happen in 3.0.2:

image

image

This is what I am getting:

image

When i turn the notifications on, the page is not even loading:

Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/dpgpsifp/psicodebate.dpgpsifpm.com.br/plugins/generic/driver/DRIVERDAO.inc.php on line 19

Strict Standards: Declaration of PKPWorkflowHandler::initialize() should be compatible with PKPHandler::initialize($request) in /home/dpgpsifp/psicodebate.dpgpsifpm.com.br/lib/pkp/pages/workflow/PKPWorkflowHandler.inc.php on line 506

Warning: Cannot modify header information - headers already sent by (output started at /home/dpgpsifp/psicodebate.dpgpsifpm.com.br/plugins/generic/driver/DRIVERDAO.inc.php:19) in /home/dpgpsifp/psicodebate.dpgpsifpm.com.br/lib/pkp/classes/template/PKPTemplateManager.inc.php on line 855

Warning: Cannot modify header information - headers already sent by (output started at /home/dpgpsifp/psicodebate.dpgpsifpm.com.br/plugins/generic/driver/DRIVERDAO.inc.php:19) in /home/dpgpsifp/psicodebate.dpgpsifpm.com.br/lib/pkp/classes/template/PKPTemplateManager.inc.php on line 856

The code didn’t work, it is showing an error now:

image

Hi @Hugo_Melo

There is a bug in OJS 3.1 so that the custom e-mail templates are not displayed, s. getCustomTemplateKeys parameters · Issue #3046 · pkp/pkp-lib · GitHub. Thus, to solve it for you, you would need to make these changes: pkp/pkp-lib#3046 getCustomTemplateKeys parameters by bozana · Pull Request #3047 · pkp/pkp-lib · GitHub.

Best,
Bozana

@bozana, you are great!
However, my 3.1 installation doesn’t have any of those 2 files you describe. :confused:

Man, I am sorry, I was looking at the wrong dir.
It worked like a charm! Brilliant!

Thank You very much,

Maybe you can take a look at this problem and point me a solution, please?