Site gone down with /cgi-sys/suspendedpage.cgi

I just published an issue and then the web host server closed down so no website and no email. Could this be because we have a number of bounce backs from false subscribers?

Can’t tell you exactly which verion of OJS I’m running as i can’t access the site! But it is 3.02 recentish

https://murmurations.cloud/cgi-sys/suspendedpage.cgi

Hi @gail,

Does your web host provider provide an opportunity to migrate your files to a new hosting service?
Typically when this message is displayed its an issue with the hosting provider – and not OJS. If your hosting provider is shutting down, you’ll most certainly want to be migrating your OJS instance to a new host.

-Roger
PKP Team

The web host has responded and unsuspended our site and email quickly. The site got automatically suspended because OJS sent out more than 200 emails to announce a new issue. The web host suggested we use a mailchimp equivalent instead.

Have others here had that issue with web hosting services?

Hi @gail,

Thanks for sharing. I’ve never personally seen that happen - that’s not to say that others in the community wouldn’t have experienced that. I could see how if the host was vigilant about email service in a shared hosting environment might take that approach, though.

-Roger
PKP Team

Hi @gail

Looks like your site have been hit by spammers.

  • First you need to disable your mail (ie: edit your config.inc.php) to avoid more mails.
  • Second, enable catpcha and honeypot plugins to avoid more fake users.
  • Finally, you need to clean your user list going to your DB and checking for spam user’s patterns (or doing it manually). This post could help you with this last task.

Once you finish, you will be able to renable the mail and go back to normal.

Cheers,
m.

Ok, I read you too fast and my answer is not accurate.

First, let me clarify this is not an issue with OJS… it’s a problem with your hosting provider.

When you publish a new number, OJS sends an email to all your readers (you can avoid this when you publish, if you uncheck the “mail notification” checkbox). If you ask to notify all your users… this is exactly what OJS will do.

If your hosting provider has a 200 mail limit for the number of messages you can send… (and looks like this is what they say) and you have more than 200 users (that is quite usual) you will hit this limit.

You can fix this in some different ways (chose the one or ones that fit better with you):

  1. Avoid the mail notification: Next time you publish, remember to uncheck the “notification” checkbox.
  2. Clean up your user’s database: Remove all the spam users you got in your DB following the instructions I explained in the former post.
  3. Move to a less restrictive hosting provider: I have journals with more than 10K users and the editors like to notify them all.
  4. Talk with your hosting to extend your service: Usually hosting have extended services with advanced features.
  5. Mail with a different smtp server: It can be tricky, but you can try to configure your OJS to mail using a different smtp server.

Hope this answer helps you better than the former one.

Cheers,
m.

1 Like