Sending emails on works workflow in OJS 3.0.1 (and 3.0.0 too)

Hi,

I install a new instance of OJS 3.0.0 and had that issue, later update to 3.0.1 but it’s the same, I can receive emails from user registration, password recovery, but none of the emails from the internal workflow of the submissions (notify author, reviewer, etc… ), It uses the mail() function by default. I have other journals with version 2.4.8 on the same server and they work perfectly. Is this a bug or some bad configuration? also tried to check some error logs but nothing.

Regards,

José Carvalho

Hi @josekarvalho,

The likeliest thing is that your mail server is not delivering the messages due to e.g. DMARC requirements. I’d suggest checking your server’s email delivery log for details.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

I just checked the mail log but nothing there (I found another email with that issue, but not from OJS). Also tested this with another journal on the same infrastructure and is exactly the same. I have already sent an email to the team who manages the server.

The strange here is why I receive emails from a user registration. And if I try to send directly an email from the user list to the same user, nothing happens. Also activate the erros and warning logs but nothing there too.

OJS3 uses different ways to send emails for the registration process or for the internal workflow?

Regards,

José Carvalho

1 Like

Hi @josekarvalho,

The mail server could be refusing to deliver messages for any number of reasons – the wording of the message, the sender or receiver’s domain name, the number of messages sent in the last 24 hours, etc. There’s no way to debug this from OJS; you’ll have to check your mail server’s configuration/logs.

Regards,
Alec Smecher
Public Knowledge Project Team

Thanks @asmecher! It will be something at that level for sure!

Regards,

José Carvalho

Hi @josekarvalho, Have you solved this email problem?
I am facing the same as yours, I receive emails from user registration, notification when a new issue has created, and send email manually to the desired user, but none of the emails from internal workflow of submissions and password recovery as well.

Thanks in advance

Eddie

Hi @eddhie,

I just configured the journal to use SMTP, in this case with GMAIL SMTP and an account, so on the config.php file use this:

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = “ssl://smtp.gmail.com”
smtp_port = 465

; Enable SMTP authentication
smtp_auth = PLAIN
smtp_username = “youremail@gmail.com
smtp_password = “your password”

This may be related with mail policies of the hosting service…

Regards,

José Carvalho

Hi @josekarvalho,

Many thank your help, I have solved this issue

Regards,

Eddie

We have the same issue but our server produce a very rare error message. The Author receive confirmation email after submission, But the other emailing:
Assigning Editor
Editor to Reviewer
Reviewer to Editor
Editor to Author
do not work, manually or automatically.

Please advise!

Our OJS 3.0.2
Server is Debian 8.5 with Plsk 12.5

Here is the Apache error message is

AH01071: Got error 'PHP message: PHP Warning: file_exists(): open_basedir restriction in effect. File(/lib/pkp/js/lib/jquery/plugins/validate/localization/messages_en_US.js) is not within the allowed path(s): (/var/www/vhosts/dotaca.com/:/tmp/:/usr/share/pear:/usr/share/php:/var/lib/php5:/lib/pkp/js/lib/jquery/plugins/validate/localization/:/lib/pkp/lib/vendor/moxiecode/plupload/js/i18n/) in /var/www/vhosts/dotaca.com/ojs.dotaca.com/lib/pkp/classes/template/PKPTemplateManager.inc.php on line 571\nPHP message: PHP Warning: file_exists(): open_basedir restriction in effect. File(/lib/pkp/js/lib/jquery/plugins/validate/localization/messages_en.js) is not within the allowed path(s): (/var/www/vhosts/dotaca.com/:/tmp/:/usr/share/pear:/usr/share/php:/var/lib/php5:/lib/pkp/js/lib/jquery/plugins/validate/localization/:/lib/pkp/lib/vendor/moxiecode/plupload/js/i18n/) in /var/www/vhosts/dotaca.com/ojs.dotaca.com/lib/pkp/classes/template/PKPTemplateManager.inc.php on line 571\nPHP message: PHP Warning: file_exists(): open_basedir restriction in effect. File(/lib/pkp/lib/vendor/moxiecode/plupload/js/i18n/en_US.js) is not within the allowed path(s): (/var/www/vhosts/dotaca.com/:/tmp/:/usr/share/pear:/usr/share/php:/var/lib/php5:/lib/pkp/js/lib/jquery/plugins/validate/localization/:/lib/pkp/lib/vendor/moxiecode/plupload/js/i18n/) in /var/www/vhosts/dotaca.com/ojs.dotaca.com/lib/pkp/classes/template/PKPTemplateManager.inc.php on line 588\nPHP message: PHP Warning: file_exists(): open_basedir restriction in effect. File(/lib/pkp/lib/vendor/moxiecode/plupload/js/i18n/en.js) is not within the allowed path(s): (/var/www/vhosts/dotaca.com/:/tmp/:/usr/share/pear:/usr/share/php:/var/lib/php5:/lib/pkp/js/lib/jquery/plugins/validate/localization/:/lib/pkp/lib/vendor/moxiecode/plupload/js/i18n/) in /var/www/vhosts/dotaca.com/ojs.dotaca.com/lib/pkp/classes/template/PKPTemplateManager.inc.php on line 588\n', referer: http://ojs.dotaca.com/index.php/IJSTEM/admin/systemInfo?versionCheck=1

Hi @Dilan_Rostam,

That error isn’t related to email sending – it’s filed here, but we haven’t been able to replicate the problem locally for testing/fixing so it’s unresolved so far.

Regards,
Alec Smecher
Public Knowledge Project Team

Is there any way work around this issue please?

Hi @Dilan_Rostam,

Have you worked through the suggestions already in this thread?

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

I got a new issue regarding this email notification. I tested our journal by registering a new author. The registration process was successful, but we did not get any email notification to the new author.
But then, I tested again registering a new author through the journal manager account, it worked, We got the email notification.
Would you please help me how to solve this problem?

Thank you

Hi @eddhie,

See e.g. this response.

Regards,
Alec Smecher
Public Knowledge Project Team

We end up to reconfigure any files, and I do this think this is right. The OJS heavily rely on sending emails, It should be a normal setting in the application setting to deal with this.

I have defined our G Suite and its working fine, DMARC1, DKIM1 and all setting, no issues, We even disabled the OPNE_BASEDIR to eliminate any issues. However the issue still remain :frowning:

@    IN MX 1    ASPMX.L.GOOGLE.COM.
@    IN MX 5    ALT1.ASPMX.L.GOOGLE.COM.
@    IN MX 5    ALT2.ASPMX.L.GOOGLE.COM.
@    IN MX 10   ALT3.ASPMX.L.GOOGLE.COM.
@    IN MX 10   ALT4.ASPMX.L.GOOGLE.COM.
@    IN TXT     "v=DMARC1; p=none; rua=mailto:xxxxxx@dotaca.com"
@    IN TXT     "v=spf1 include:_spf.google.com ~all"
@    IN TXT     "v=DKIM1; k=rsa; xxxxxxxxxxxxxxxx"

Did this work for you please?

Do you need the quatation around the email and password?

This link advise different setup,

https://support.google.com/a/answer/176600?hl=en

and new ojs config support only SSL not PLAIN

[email]

; Use SMTP for sending mail instead of mail()
 smtp = On

; SMTP server settings
 smtp_server = "smtp.gmail.com"
 smtp_port = 587

; Enable SMTP authentication
; Supported mechanisms: ssl, tls
 smtp_auth = ssl
 smtp_username = email
 smtp_password = pass

Hi @Dilan_Rostam,

Yes, all configs are as they have been copied here. And for me it was the workaround I manage to have all emails working on the journal.

Regards,

José Carvalho

I think we have server issue. It is too secure we need to tune that down.

Dear Dilan_Rostam
Have you solved the problem? I have the same issue , emails does not work and I did the following configuration and I tried the port 25, 465 and 587 but nothing working:

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = “ssl://smtp.gmail.com”
smtp_port = 465

; Enable SMTP authentication
smtp_auth = SSL
smtp_username = “username”
smtp_password = password"

Hi,

In our case the issue is only server setting. We installed the OJS in different hosting and everything worked fine. Please check this in your case. Install that in different server to check. Here you can use free hosting to check

https://www.000webhost.com/