Revisions > Upload File, Access Denied for author in OJS 3.2.1-2

App-version: OJS 3.2.1-2 (

Submission is in Review Round 1

Round 1 Status
The submission must be resubmitted for another review round.

When author tries to click Upload File in Revisions (Workflow > Review > Round 1 > Revisions > Upload File), a dialog appears with the message Access Denied.

I have confirmed this, as I logged in to the user in question, and indeed, it is impossible to upload a revised file as I then get the popup with the message Access Denied.

I have checked that the Author role indeed has access to the Review stage in Users & Roles > Roles.

I also tried giving the author permission to “Allow this person to make changes to the publication, such as the title, abstract, metadata and other publication details. You may wish to revoke this privilege if the submission has received a final check and is ready for publication.”, but the problem with Acces Denied when using the Upload File link persists.

Note that when logging in as a section editor assigned to the submission, the Upload File link works as intended.

Unfortunately this doesn’t trigger any error messages in the server logs or in the browser console, so it is hard to troubleshoot.

Eirik Hanssen
OsloMet University Library

1 Like

The same problem appears in the case of reviewers trying to add file to the review.

1 Like

Did you ever figure this out? I found a work-around using the “Review Discussion” area, which allows authors to contact the editor and upload their documents; but, it doesn’t follow the flow as outlined in the tutorial video: Editorial Workflow in OJS 3 - Module 7 - Responding to the Reviews - YouTube

Hi @Eirik_Hanssen,

I recently posted the same observation about access being denied for an author upload of a revision file (Authors can't upload revised review file OJS 3.2). I’m aware of the workaround mentioned in a reply, whereby the author uses the Discussions tool and attaches the file there. But, in my post, I mentioned my preferred workaround, which is to make sure that another editorial decision is entered with the box checked for there not being another round of review. It doesn’t matter if there actually is another round. I also enter the decision without sending an email so as to not confuse the author. HOWEVER, there appears to be a problem with the software that should be fixed. No such workarounds should be needed.

Thanks for your suggestion. I don’t consider this solved. I hope we can hear from the developers soon, as @pmfalrrell writes, no such workarounds should be needed.

Another problem with using Discussions as the workaround is that the files attached to Discussions do not appear in the list of files that can be sent on to the next stage of the workflow. If OJS would do that, that would be so nifty.

– Marianne Reed, KU Libraries

This is really strange. I have not changed anything at all on the server or in OJS settings since reporting this issue, but I am no longer getting Access Denied when uploading revised manuscripts from authors in review round 1 where Round 1 Status is that “The submission must be resubmitted for another review round”.

Unfortunately this problem still persists. I logged in as several authors and tried to upload under Revisions, both in Round 1 and 2 of the review stage, and the “Access Denied” notification still pops up either way.

I noticed this error does not occur if the submission is in the copyediting stage (logged in as an author), but that’s beside the point, considering how the submission needs to go through the review stage first.

Hope this can be resolved soon. Thank you.

I’ve confirmed this is a bug in 3.2.1-2. It was introduced in 3.2.1-2, so previous versions should not be effected. I’ve filed this to be fixed and you can follow progress at Author can not upload revisions when decision is to resubmit for review · Issue #6529 · pkp/pkp-lib · GitHub.

1 Like

Does 3…2.1-2 mean the same as I am seeing the same issue.

@SACJ_Editor yes it’s the same. We’ve now released 3.2.1-4 so you should update to that version as soon as possible.

If the release have fixed it (no more complaints anyway) for authors uploading revisions, an editor attempted to upload a marked up file from a reviewer as part of the decision email, where there is an interface to upload a file, and also got Access Denied.

Is this also a known bug?

Yes, @philipmach, this is the same bug. It has been fixed and the fix will go out with 3.3.0-4. If you are still running 3.2.x, you may need to apply the patch manually. Details are in this issue: [OJS] Access denied for journal editor when adding new file in Request revisions dialog · Issue #6762 · pkp/pkp-lib · GitHub

1 Like

I’m having a similar problem in OJS version 3.3.10 right now.

I created a new topic on this subject. I would be glad if anyone has a solution suggestion.