Registration doesn't work after enabling ReCaptcha

Hi!
I have a server installed with OJS 3.1.2-1. In order to increase security in my environment I enabled ReCaptcha in config.inc.php just by setting recaptcha = on, adding recaptcha keys, and captcha_on_register = on.

I try to register once and it worked perfectly. But now I’m trying to register again and I only get an Error 500.

This is my ojs log when I’m trying to register:
[Wed Nov 06 09:08:40.352818 2019] [php7:warn] [pid 56138] [client 192.168.128.73:5278] PHP Warning: Declaration of RegistrationHandler::validate($request) should be compatible with PKPHandler::validate($requiredContexts = NULL, $request = NULL) in /home/ojs/lib/pkp/pages/user/RegistrationHandler.inc.php on line 19, referer: https://erevistas.publicaciones.uah.es/

[Wed Nov 06 09:08:40.367964 2019] [php7:warn] [pid 56138] [client 192.168.128.73:5278] PHP Warning: Declaration of RegistrationForm::validate() should be compatible with Form::validate($callHooks = true) in /home/ojs/lib/pkp/classes/user/form/RegistrationForm.inc.php on line 21, referer: https://erevistas.publicaciones.uah.es/

[Wed Nov 06 09:08:40.462109 2019] [php7:error] [pid 56138] [client 192.168.128.73:5278] PHP Fatal error: Uncaught Error: Call to a member function getId() on null in /home/ojs/plugins/generic/orcidProfile/OrcidProfilePlugin.inc.php:253\nStack trace:\n#0 /home/ojs/plugins/generic/orcidProfile/OrcidProfilePlugin.inc.php(289): OrcidProfilePlugin->buildOAuthUrl(‘orcidAuthorize’, Array)\n#1 /home/ojs/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_filterhandler.php(63): OrcidProfilePlugin->registrationFilter(’\trunFilter(‘output’, '\trender(false, 1)\n#4 /home/ojs/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(134): Smarty_Internal_TemplateBase->_execute(Object(Smarty_Internal_Template), NULL, 'fe8 in /home/ojs/plugins/generic/orcidProfile/OrcidProfilePlugin.inc.php on line 253, referer: https://erevistas.publicaciones.uah.es/

I’ve tried going back my config.inc.php by configurating recaptcha = off, commented recaptcha keys, and captcha_on_register = off, but error 500 persists.

I’ve found out that if you are in the main page https://erevistas.publicaciones.uah.es/:

and you try to register, then url becomes “https://erevistas.publicaciones.uah.es/index.php/index/user/register
and it doesn’t work:

However, if you log into the system with a registered user, you edit a journal called rev1:

and then log out, it appears another screen with url " https://erevistas.publicaciones.uah.es/index.php/rev1/login" (notice now it adds “rev1” to the url):

If you try to register on that screen, url becomes “https://erevistas.publicaciones.uah.es/index.php/rev1/user/register” and then it works:

I don’t know if it’s a normal functioning of OJS or there’s something wrong.

I’ll be so thankful if you could help me.
Thanks in advance.
Regards.

Hi @rmga,

The issue isn’t with recaptcha, it’s with ORCID. Did you also recently upgrade, perhaps? Are you using the latest version of the ORCIDprofile plugin?

Cheers
Jason

Hi jnugent,

sorry, I was re-editing my message when you answered my question.
Please, I’d appreciate if you could read the end of my question to see what I found out about the issue.

I haven’t upgraded the system at all.
Thanks so much!
Regards.

Hi @rmga,

Can you try disabling the ORCID profile plugin temporarily to see if that lets you register?

Cheers
Jason

How can I do that?
Cheers.

As journal manager, you can go to Settings -> Website -> Plugins tab and uncheck the box for the ORCID profile plugin. It is in the “Generic” category.

Cheers
Jason

Hi,
Effectively, If I disable ORCID profile plugin I can register without problem.
But I understand I need it enabled. What can I do?
Thanks.

Since you’re using OJS 3.1.2, I’d go and get the newest version of the 3.1.2 plugin here:

You’ll need to upload it onto your server and replace the plugins/generic/orcidProfile directory. You can run php lib/pkp/tools/installPluginVersion.php plugins/generic/orcidProfile/version.xml to install it.

Cheers
Jason

Finally, my problem was a wrong configuration in config.inc.php. My public_files_dir variable wasn’t relative and it was giving me more troubles such as not to upload images, not to show images already uploaded.
Thanks so much for your help.
Regards.