PKP PN Plugin Setting error

When i click on PKP PN Plugin setting following JSON Error Alert returns

Failed Ajax request or invalid JSON returned. PKPPN Error .

I am using OJS 3.2.1.2 and PKP PN 2X.
when i inspected page; found that 500 erorr in following pages

/files/$$$call$$$/grid/settings/plugins/settings-plugin-grid/manage?verb=settings&plugin=plnplugin&category=generic&_=1611504543123

/files/$$$call$$$/grid/settings/plugins/settings-plugin-grid/manage?verb=settings&plugin=plnplugin&category=generic&_=1611504543124

/files/$$$call$$$/grid/settings/plugins/settings-plugin-grid/manage?verb=settings&plugin=plnplugin&category=generic&_=1611504543125

Hello @Sufyan_Sher,

A similar error for the PKP PN has been reported here: [OJS 3.1.2] PKP PN Plugin error - Failed Ajax request or invalid JSON returned [close] - #5 by diegomejia07 - you may wish to try what is suggested in the forum there to resolve this issue.

Best regards,

Roger
Public Knowledge Project Staff

Dear @rcgillis
Have a look at the title of the window. It says “test title” and comes from js/build.js. It’s in the package from https://pkp.sfu.ca/ojs/download/ojs-3.2.1-3.tar.gz

I guess that’s a bug, isn’t it.

All the best
Klaus

what will be solution?

The “test title” is not causing the Failed Ajax request or invalid JSON returned. But maybe there’s more hickups in js/build.js.
@Sufyan_Sher Where did you get your installation package from?

from settings>website>plugins

I was referring to the whole OJS installation package, not the plugin.

it was installed by another developer. I dont know from where he did. but last time when i upgrade it to 3.2.1.2. I downloaded tar.gz from https://pkp.sfu.ca/ojs/ojs_download/

Hi all,

Does anything helpful appear in your PHP error log?

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher
Besides the 500 error as reported above, I found some undefined 404. But I need to further investigate and compare with my test system.
Best
Klaus

Dear @asmecher
the “test title” originates from ui-library/FieldArchivingPn.vue at d41c26eed44a9a3c2d35d87b8a8b297567e05532 · pkp/ui-library · GitHub
The Failed Ajax request or invalid JSON returned is because the plnplugin breaks all settings-plugin-grid. Let me add that my plugin settings page doesn’t load on my production site. So once I rename the folder /plugins/generic/pln to e.g. capital letters, my plugin-settings pages load again. Just that plnplugin is then considered not to be installed. It’s similar to this post PKP PLN plugin OJS 3 - #40 by Eldhelion
Any ideas?

OJS 3.2.1.3

Dear @asmecher
this is what I can report so far:

  1. as for the “test title”:
  • going via Settings -> Website -> Plugins -> PlnPlugin Settings the modal shows the correct title
  • going via Settings -> Distribution -> Archiving -> plugin settings the modal shows the “test title”
  1. as for the Failed Ajax request or invalid JSON returned
  • there must be something wrong with the settingsUrl somewhere in the code. On the console I’ve testet the disablePluginUrl and enablePluginUrl and both worked fine. Other plugins that use /$$$call$$$/grid/settings/plugins/settings-plugin-grid/manage?verb=settings&plugin=... work fine.
  • the response to the AJAX call is empty and causes a 404.
  • Alternatively, after uninstalling the plugin, I’ve copied the plugin’s stable-3_2_1 branch and did composer install and activated it again with no changes, still no useful response.
  • It should be mentioned that the plugin has an interesting readme.md that should be made available or linked in the backend.

Hello everyone,

For me the solution was to upgrade the PHP version on my server from PHP 7.2 to PHP 7.3. now it works very well.

1 Like

i hve upgrade my php but StiLL Hving iSSue