ORCID redirect URI suddenly does not match

After upgrading OJS 3.1 to OJS 3.3, which worked well, the users suddenly receive an error when automatically redirected to Orcid. The error is: “Registered URI does not match your registered redirect URIs”. I do not understand why this happened because we did not touch the code during the upgrade (at least, that is what I think).

I am not sure where can we check for the URI in the OJS installation? I checked the ojs installation folder setting in config.inc.php and it is the same as before the upgrade.

On a related matter, I do not know what exactly Orcid section does in config.inc.php. These lines are all commented with the semicolon. But they were also commented in the previous installation but the Orcid worked properly.

I know there were a couple of threads related to similar problems but I did not find the correct answer.

Kind regards,



Do you have the credentials like here

I think this you have to check with the domain you registered with orcid against the one you are authenticating.
Should be a mismatch