"ORCID error" exporting xml from crossref exportation plugin

  • Application Version:OJS 3.2.1-1

  • Description of issue:


<?xml version="1.0" encoding="UTF-8"?>

<doi_batch_diagnostic status=“completed” sp=“ds3.crossref.org”>
<record_diagnostic status=“Failure”>

Error: cvc-complex-type.2.4.d: Invalid content was found starting with element ‘ORCID’. No child element is expected at this point.


At first I thought the profile link to ORCID was wrong. But you can check that the link works correctly: El género Phytophthora (Peronosporales) en Argentina | Boletín de la Sociedad Argentina de Botánica

Does anyone have any idea what might be going wrong?

1 Like

I have the same error.
Have no idea why it happened (

Hi @Oleksandr_Radkevych, @didoemilio,

Can you please attach the XML file here to investigate it?

Regards, Primož

I attach the XML!


Hi @Oleksandr_Radkevych,

Hm, sorry, I don’t find the error. Why don’t you try to send the XML and the error to the CrossRef support and ask for help?

Regards, Primož

From now I wait answer from them )

Some news from crossref?

Hi, Felix

from crossref nothing useful
I was reinstall ojs 3.2.0
Everything works well

This issue is resolved in OJS master branch on 19.10.2020 by the following PR.


I’m getting same error on OJS 3.2.1-4 (not sure if it also happens with last stable).

The fix was published here but I think it was not included in 3.2 branch. If it fixes the issue, would be great if it can be included in last 3.2 stable.

For others falling know in this same issue (while it was added to 3.2 or if you don’t know how to apply the patch), notice it only happens when authors have an orcid AND multilang names. So an obvious workaround is… removing name and givenname in all langs and keep it in ONLY primary language. And in the few cases where this is not possible, you can download the xml, edit (as explained in gitHub) and upload to CrossRef manually.


1 Like