Error: cvc-complex-type.2.4.d

Hi.
OJS 3.2.1.1

I have problem with registration new article doi in Crossref by export plugin in OJS system:
We previously changed the ISSN for journal

<?xml version="1.0" encoding="UTF-8"?>

<doi_batch_diagnostic status=“completed” sp=“ds5”>
<submission_id>1475316612</submission_id>
<batch_id>_1596918755</batch_id>
<record_diagnostic status=“Failure”>

Error: cvc-complex-type.2.4.d: Invalid content was found starting with element ‘ORCID’. No child element is expected at this point.

</record_diagnostic>
<batch_data>
<record_count>1</record_count>
<success_count>0</success_count>
<warning_count>0</warning_count>
<failure_count>1</failure_count>
</batch_data>
</doi_batch_diagnostic>

Anyone know this error type?
And what I need to do with it?
Thank you )

Man has same error: "ORCID error" exporting xml from crossref exportation plugin

can you please send the xml file, to check if it is valid. Generally a valid ORCID ID looks like this.
https://orcid.org/0000-0001-6192-xxxx

I want to know, if you have correct data in the oricd entry.

Another question is, did you update your system from ojs 3.2.0 to 3.2.1

Hi
I attach the XML!
XML

Yes. I was update OJS from 3.2.0.2 to 3.2.1.1

Your oricd ID is http.
Can you change it to https and let me know if it is valid ?
You can either change it in database or delete in the backend and re-enter it.

<xsd:element name="ORCID">
<xsd:annotation>
<xsd:documentation>
The ORCID for an author. The schema performs basic pattern validation, checksum validation is performed upon deposit via a system check.
</xsd:documentation>
</xsd:annotation>
<xsd:complexType>
<xsd:simpleContent>
<xsd:extension base="orcid_t">
<xsd:attribute default="false" name="authenticated" type="xsd:boolean"/>
</xsd:extension>
</xsd:simpleContent>
</xsd:complexTy

Error from CrossRef metadata quality check
https://www.crossref.org/02publishers/parser.html
file with https.
File: crossref-20200811-020421-articles-1.xml

[Error] :49:20: cvc-complex-type.2.4.d: Invalid content was found starting with element ‘ORCID’. No child element is expected at this point.

I have a problem with all the articles in the issue
Perhaps I need to reinstall OJS

Receive answer from Сrossref:

So it was just that there were two elements in the wrong order in the xml file. The ORCID and alt-name elements were in the wrong order, they showed as:

<alt-name>
    <name language="en">
        <surname>Radkevych</surname>
        <given_name>Valentyna</given_name>
     </name>
 </alt-name>
 <ORCID>http://orcid.org/0000-0002-9233-5718</ORCID>

but they needed to be around the other way as per the schema here: http://data.crossref.org/reports/help/schema_doc/4.4.2/schema_4_4_2.html#person_name

<ORCID>http://orcid.org/0000-0002-9233-5718</ORCID>
            <alt-name>
              <name language="en">
                <surname>Radkevych</surname>
                <given_name>Valentyna</given_name>
              </name>
            </alt-name>

I hope this helps and if you have any further question or queries on this then please do not hesitate to contact us again.

1 Like

I was reinstall 3.2.1.1 - no result
Downgrade from 3.2.1.1 to 3.2.0.2 - work well, but not the current version :frowning:

Hi @Oleksandr_Radkevych and @Dulip_Withanage

I want to share how I got success in registering new DOIs using Crossref XML plugin version.

The ORCiD Profile plugin v1.1.2.5 released on 2020-08-16 is also installed and activated. OJS version is 3.2.1-1.

I was getting the same error during automatic/manual registration using Crossref XML registration plugin.
So, I exported the articles as XML batch file without checking XML validation option.
Then, moved all <ORCID>...</ORCID> nodes just above <alt-name> node throughout all records.

Then, I uploaded this XML file after logging into Crossref admin tool at URL.
https://doi.crossref.org/servlet/useragent
Submissions --> Upload --> Choose File (Metadata)

I think the XML file schema needs to be updated to match current Crossref schema and this file is produced by Crossref XML Export Plugin. I don’t know if this error plugin has been already fixed on Github, but I will wait for the next OJS 3 update.

Regards,

@drugurkocak

Thanks a lot for taking time and documenting it properly.

Appreciate your contribution.

(See also an associated pull request: https://github.com/pkp/ojs/pull/2882)