OMP 3.3.0-7 – Review Discussion not working for Internal Reviewer

I have a fresh new installed OMP 3.3.0-7 site whose complete system informations are:

Version Major Minor Revision Build Date installed 3 3 0 7 30-07-2021

Server Information
Setting Name Setting Value
OS platform Linux
PHP version 7.3.14
Apache version Apache/2.2.15 (CentOS)
Database driver mysql
Database server version 5.5.45-log

I have issues with Internal review stage. In particular, the Review Discussion is not working for Internal Reviewers.

Clicking on the “Add discussion” button the modal window for sending the Discussion gets open correctly.


When you try to save the discussion clicking the OK button an error pops up saying:

“Errors occurred processing this form
A selected participant is not assigned to this stage.”

“Internal Review” and “Series Editor” partecipants had been correctly selected.


Making multiple attempts to save the discussion I also had the following error:

“You do not have permission to access this discussion”


I also tried to open a discussion with Internal Reviewer with Series Editor role.
In this case the discussion gets saved but the Internal Reviewer don’t see it in the Review Discussions Panel (see following screenshots showing both Internal Reviewer and Series Editor sides)



Considerig the issues already posted here

it seams that the whole Internal Review stage needs to be checked.

Thanks in advance for any help or suggestions to fix this issue.

@NateWr @bozana @asmecher @Vitaliy

Hello @NateWr
Does the fix that you did for OMP 3.3.0-4 and 3.3.0-7 - Authors see an empty "Internal Review" tab
also fix this problem?

Hi @razzi ,
in OMP 3.3.0-8 , I tried to reproduce the error your describes.

I cannot reproduce the error you describe.

When you log as the internal reviewer, you should be able to see the message you got from the series editor. That is by design. Have you checked, if you get javascript errors or php errors ?