OJS software with not all

Hi everyone,

I am new with OJS software and I am having problems.
I installed the software but then I’m not able to set to payments trough the website. When I read the manual, I see there is no correspondence from what I see on the website and what it is written on the manual. Please, can you help me?


In the picture you can see what I see. there are no options as described in this page: https://pkp.sfu.ca/ojs/docs/userguide/2.3.3/journalManagementPaymentOptions.html

Hi @virgamesh

This documentation you are posting is related to a previous OJs version.

You can see in this post a link to creating REST API application in PAYPAL:

Israel Cefrin
Public Knowledge Project Team

Hi Israel. I’m trying to help Anita with this problem. I see people with this OJS 3.1 software installed have the same look (dark blue); and I see the instruction manual shows a beige/cream/yellow look. However, there is no “Payments” option on the blue section.

If we look at this bug report, we see that there IS a payments option

BUT … going to the paypal link below about REST APIs doesnt seem to help. How do we turn on or otherwise activate the “payment” button?

Hi Israel. OK it has gotten much worse. I tried to upgrade to the latest version and now it won’t install. I even deleted the software and the database entirely. If I go to the site it now says:

DB Error: Table ‘ojs.journals’ doesn’t exist

But I already did this:

create database ojs;
Query OK, 1 row affected (0.00 sec)
grant all on ojs.* to ‘ojs_issa’;
Query OK, 0 rows affected (0.00 sec)
flush privileges;
Query OK, 0 rows affected (0.00 sec)

so why is it trying to read pre-existing tables if I am installing from scratch?

Here’s the OJS config file lines:

; Database Settings ;

installed = Off


driver = mysql
host = localhost
username = ojs_issa
password = ****
name = ojs

To reinstall I used rm -rf on the software, tar xfvz on the tarball, then created the database in mysql as shown above.

OK so what I did was turn the state to installed = on, then installed = off again. That seems to have worked to get me to the installer screen.