OJS 3 can't login, no errors

Hi,
I’ve updated OJS 2 to OJS 3, but now I can’t login and no errors are showing (incorrect username or password).

Gregorio

See e.g. this thread. If that doesn’t resolve your situation, post what you’ve tried and what the effect was.

Regards,
Alec Smecher
Public Knowledge Project Team

Thanks! Solved.

I’ve changed the session_check_ip setting to Off.

Gregorio

Hi

I started facing the same login problem with OJS 3, installed last month, the login and registration was working fine until two days back. I tried to login with different browsers (IE, Chrome, Firefox) and on different networks/computers as well, but not able to login now. When try to login, the same page refreshes with login form. When password is wrong, the message for wrong login credential reflects. When tried to register new user, it shows form not submitted properly.

I checked the suggest post and other posts on the forum, We tried followings:

  1. I changed the cookies name in configuration file (as we are using 2.4.8 version on other domain, on which login working on same computer/network, presuming if this is because of same cookies name as suggested on other posts).
    → still not able to login to OJS 3
  2. then also set session_check_ip setting to Off in configuration file.
    → still not able to login to OJS 3
  3. also tried by deleting the records in ‘session’ table (through phpmyadmin ), but no luck (on first attempt showed system failure, in next attempt, new record was inserted in the table).
    The users table shows last login time to current attempt of login. May be login is taking place, but session not starting.
  4. Also contacted server host support, but they said no changes made to server recently.

The server php version is 5.6 (checked through cpanel).

You may check the OJS3 installation on [http://pubs.thesciencein.org/journal/index.php/jmns](http://pubs.thesciencein.org/journal/index.php/jmns Journal of Materials NanoScience)

Any suggest how to resolve the issue.

bhupender

Solved. The login problem (and registration) was solved by disabling the ‘ramcache’ for the journal domain/subdomain (disabled through cpanel). OJS3 was installed on new subdomain and after sometime of use, it started showing login problem (with no error message).

Sharing if could be helpful for someone.

best

Hi, the same thing is happening to you, I try to enter the magazine and it does not leave me, it does not give an error, it sends me back to the Enter page, if I try to register a new user it gives me an error when processing the form.
I read that you could solve it by disabling the ramcache, could you explain how you did it, if it was in the files of the site or on the server?
Thank you

1-I am also facing the same problem in login with ojs3 “Invalid username or password. Please try again.” with correct userID and password… https://jjss.co.in/ijournal/index.php/index/login/signIn
2-when I tried for “Forgot your password” to reset password.
when I entered e-mail and click on “reset password” in “Forgot your password” it shows This page isn’t working
https://jjss.co.in/ijournal/index.php/index/login/requestResetPassword
3- ojs fresh installed by softacolous its work properly, but when I import database public folder and files , it again giving error.
4- after setting installed = Off in config.inc.php and run re-installation shows " This page could not be found!"
https://jjss.co.in/ijournal/index/install
Please give me details about “disabling the ramcache” and how to disable it. and again try to update.

Hi @jjss,

Check your PHP error log for details.

Regards,
Alec Smecher
Public Knowledge Project Team

All users not able to login. What to do. Plz suggest…

I’m getting same problem. Plz share the steps to resolve the issue.

Hi
I have solved it through cpanel, login to your cpanel > under advanced options > there should be ‘RamCache’ option > click > on next screen there is button ‘Enable/disable RamCache’ > then disable for the domain/subdomain on which OJS installed.
This information was provided to us by the Server people. This is the only information I can provide (this option worked for us). If you are not able to find that then contact your server host, they will provide it.
You may try by clearing the cache as well.

Actually we don’t have the cpanel. If possible plz share the config file where we can disable the ramcache.

sorry… all that i knew.

It’s Okay. Thanks for reply bro😊

Hi,

I’m also facing the same issue.