Erratic behaviour of OJS (login problems, various error messages, etc.) – SOLVED

This post describes a problem and a solution. (It took me some time to diagnose the problem and find the solution, so I hope others will benefit from this post.)

When I moved to OJS 3.2.1 (from 2.4.5) I started experiencing erratic behaviour: sometimes login worked, sometimes it didn’t (in the sense that it took me immediately back to the login page, without any information about wrong password), and when it worked, I was immediately getting all kinds of error messages, including “You are not authorized to access the requested resource”, “Access denied”, ”The current role does not have access to this operation”, etc. Also, after just a couple of clicks the system logged me out.

Other users of the same OJS installation, with the same rights, didn’t experience such problems. Also, this problem only occurred when I used a specific Internet provider: Smarty (in the UK, powered by the Three network).

The solution that finally worked was inspired by these posts:

and consisted in setting the “session_check_ip” option in config.inc.php to “Off”.

Hope this helps other people experiencing similar problems.

adamp

2 Likes