OJS installation stuck on first page, no errors anywhere after POST

I’m attaching what I can see as a full page screenshot Screenshot_2018-07-16%20OJS%20Installation


  • Linux Mint 18.3 Cinnamon 64b
  • localhost for all services
  • PHP 7.2.7-1+ubuntu16.04.1+deb.sury.org+1
  • Apache2: Server version: Apache/2.4.18 (Ubuntu)
  • MySQL: 5.7.22
  • Firefox

The issue: Can’t get passed the first install screen

There are no errors no matter what I try, there are just some warnings which can be ignored… even if the navigation menu seems to not be rendering. The logs are empty aside for these warnings.

JavaScript console is also empty. Network tab shows everything is loaded fine (200).

Permisions are set as per the attached screenshot (-R): permissions_ojs3.
I’ve also tried with the owner as www-root instead of the normal user for the writable folders. I’ve tried the recommended setup too, several times, but it’s the same result every time.

I got the sources from pkp.sfu.ca/ojs/ojs_download/ - this version being the latest Production version.