[OJS 3.1.0.1] Failed Ajax request when publishing new issue

Description of the problem I’m having.
When I try to publish a new issue, I get an error which says “Failed Ajax request or invalid JSON returned.” The content of the Ajax response seems OK, but the server sends it with a HTTP 500 error.

PHP’s error log doesn’t show anything new and, unfortunately, my web hosting provider does not allow me to see Apache’s error log nor provides any assistance with this.

Steps I took leading up to the issue:
Go to Future Issues → Click on the arrow next to the issue I want to publish → Click on “Publish Issue”

What I tried to resolve the issue:
Based on this other thread, I tried deleting the issue and creating a new one. But the error persists.

Application Version - e.g., OJS 3.1.2: OJS 3.1.0.1

Additional information, such as screenshots and error log messages if applicable:

What does the server’s error log shows? As a general rule, a status code 500 implies a fatal error at PHP level, and that’s the message which can lead you to the solution of your problem.

Thanks for your reply. PHP’s error log doesn’t show anything when the error happens. As for Apache’s error log, as I said, unfortunately my web hosting provider does not allow me to see it (probably the best would be to change provider, but it’s not possible at this moment).

Well, without evidence to start investigating, it’s hard to make a guess… :-/

I finally made a full backup and tested the issue on another server, on which I had more control. It turned out to be a problem with an uncaught exception in ARK’s plugin.