[OJS 3.1.0.1] Error in Submission setting area

Hi @maurox

Load that URL with api path and check your php error log. This may give more details about this issue.

Regards,
Israel Cefrin
Public Knowledge Project Team

Hi @israel.cefrin

now with URL: http://YOUR_JOURNAL_DOMAIN/index.php/YOUR_JOURNAL_PATH/api/v1/

show me this message:

Index of /agro/api/v1

Parent Directory
_submissions/
issues/
submissions/

yes, i wrote in my prev reply
[Mon Dec 18 13:55:22 2017] [error] [client XXXXX] PHP Parse error: syntax error, unexpected ‘{’ in /var/www/ojs3/ojs-3.1.0-1/lib/pkp/lib/vendor/slim/slim/Slim/App.php on line 299, referer: http://journalpath/index.php/pro/submissions
[Mon Dec 18 13:59:16 2017] [error] [client XXXXX] ojs2: 404 Not Found

Another (related) problem is here
http://journal/index.php/pro/api/v1/submissions?searchPhrase=&count=100&offset=0&=1513676796547

500 Internal Server Error

same error in php log
[19-Dec-2017 09:20:20 UTC] PHP Parse error: syntax error, unexpected ‘{’ in /var/www/ojs3/ojs-3.1.0-1/lib/pkp/lib/vendor/slim/slim/Slim/App.php on line 299

Hi @Tiziano

Did it happen after you modify your config.inc.php or you didn’t change anything?

Regards,
Israel Cefrin
Public Knowledge Project Team

Hi @israel.cefrin, yes i think…

Hi @Mauro

Access attempting to your URL http://journal/index.php/pro/api/v1/ returns:

This site can’t be reached
The webpage at http://journal/index.php/pro/api/v1/ might be temporarily down or it may have moved permanently to a new web address.

Please check your server if it is responding ok.

Regards,
Israel Cefrin
Public Knowledge Project Team

Hi @israel.cefrin and @maurox,
i don’t know if this suggestion can be useful for everyone, in my case i fixed my “submission pop-up problem”, changing the Localization Settings in my config.in.php file.

I explain:

from this setting:

;;;;;;;;;;;;;;;;;;;;;;;;;
; Localization Settings ;
;;;;;;;;;;;;;;;;;;;;;;;;;

[i18n]

; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = Off

; Database storage character set
; Must be set to “Off” if not supported by the database server
database_charset = Off

; Enable character normalization to utf-8 (recommended)
; If disabled, strings will be passed through in their native encoding
; Note that client_charset and database collation must be set
; to “utf-8” for this to work, as characters are stored in utf-8
charset_normalization = Off

to this setting:

;;;;;;;;;;;;;;;;;;;;;;;;;
; Localization Settings ;
;;;;;;;;;;;;;;;;;;;;;;;;;

[i18n]

; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = utf8

; Database storage character set
; Must be set to “Off” if not supported by the database server
database_charset = utf8

; Enable character normalization to utf-8 (recommended)
; If disabled, strings will be passed through in their native encoding
; Note that client_charset and database collation must be set
; to “utf-8” for this to work, as characters are stored in utf-8
charset_normalization = Off

5 Likes

Hi @maurox,

Check that your version of PHP meets OJS’s requirements (described in docs/README).

Regards,
Alec Smecher
Public Knowledge Project Team

Hi, thanks for reply.
Maybe during installation somethings gone wrong…i’ve reinstalled and it seems works

thanks!

Dear all,

I have this problem as well. I got everything working by swithing connection & database charset to utf-8 BUT simultaneuosly I lost all the special characters. We run our paper in English (www.sjlas.org), but since the authors are around the world, and many of them from Scandinavia, their names often has those characters like ä, å, ö, ø, ü. Any suggestions?

BR

Tinde

Dear Tinde,

Please post your question in separate thread and inform us which version of OJS you use and is that upgraded or freshly installed.

Thanks

Thanks a lot buddy… This worked for me… It was a headache… Kudos to you. God bless you.

@Tiziano’s solution will work in most of such situations… in my config.inc.php connection_charset and database_charset settings were set to Off. Once they were changed to utf8 the problem was resolved… hope this will help others…

2 Likes

thankyou soooo much… this answer saved my day

1 Like

A million thanks to Tiziano!! Changing the Database connection character set to utf8 was the fix!!! I had upgraded OJS from 3.2.0-3 to 3.2.1-1. I’ve spent 3 hours trying to troubleshoot the “An unexpected error has occurred. Please reload the page and try again” Logs were not helpful. Thank you so much!

1 Like

Hi @e-smartsolution,

Cross-posted: Slim Application Error & An unexpected error has occurred. Please reload the page and try again. · Issue #6261 · pkp/pkp-lib · GitHub
(It’s better to pick just one place to post a question/issue; otherwise support effort might get doubled.)

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like

thank you, this solved my problem

1 Like

2 posts were split to a new topic: Error in submission error