[OJS] Cannot send email

We recently upgraded our OJS from to Email sending was alright on but now we can’t seem to send any emails.

Here’s our email settings on config.inc.php:

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = smtp.office365.com
smtp_port = 587

; Force the default envelope sender (if present)
; This is useful if setting up a site-wide noreply address
; The reply-to field will be set with the reply-to or from address.
force_default_envelope_sender = Off

; Enable SMTP authentication
; Supported mechanisms: PLAIN, LOGIN, CRAM-MD5, and DIGEST-MD5
smtp_auth = tls
smtp_username = our_email
smtp_password = our_password

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
allow_envelope_sender = On

; Default envelope sender to use if none is specified elsewhere
default_envelope_sender = our_email

; Enable attachments in the various “Send Email” pages.
; (Disabling here will not disable attachments on features that
; require them, e.g. attachment-based reviews)
enable_attachments = On

; Amount of time required between attempts to send non-editorial emails
; in seconds. This can be used to help prevent email relaying via OJS.
time_between_emails = 3600

; Maximum number of recipients that can be included in a single email
; (either as To:, Cc:, or Bcc: addresses) for a non-priveleged user
max_recipients = 10

; If enabled, email addresses must be validated before login is possible.
require_validation = Off

; Maximum number of days before an unvalidated account expires and is deleted
validation_timeout = 14

Our PHP Error Log shows this error:
OJS SMTPMailer: Did not receive expected 250 (2)

At first, our new OJS (version 2.4) and our old OJS 2.3 were hosted on different domain.
Let’s say that OJS 2.3 were running on domain1.com and OJS 2.4 were running on domain2.com.

Our email, however, was address@domain1.com (it uses the OJS 2.3 domain). We thought that might be the cause and that our email address must be the same as the domain that runs the OJS. So we moved our OJS 2.4 to domain1.com but the email is still not being sent.

Any helps would be appreciated and please ask me if I didn’t provide enough information for you to help. Thank you!

Hi @Theofratus,

The version of OJS that you’re using is no longer supported by PKP. I recommend that you upgrade to the newest version of OJS, as it is possible that your issue will be resolved by upgrading. However, other community members may wish to offer assistance.

Upgrading instructions are available in the PKP Administrator’s Guide and as part of our [Upgrade Guide] (https://docs.pkp.sfu.ca/dev/upgrade-guide/).

Information about the latest version of OJS can be found on the PKP Website

PKP Team


is there no support available for older version of OJS?

Hi @Theofratus,

Here on the forum, we (PKP staff) have a policy of only supporting version 3.2 or higher (see here: Welcome to the PKP Community Forum! (under “What software applications and versions are supported?”) That said, if other community members are familiar with your issue, they may wish to comment.

PKP Team

Alright I understand. I don’t think we can upgrade to later versions anytime soon as we currently have a rather urgent use of our current OJS. We’ll upgrade it though, just probably not this month. In any case, if there are someone out there who can help then I’ll appreciate it very much.

I have solved the problem.

Apparently, OJS doesn’t support TLS. My solution is to add TLS support to OJS


This topic was automatically closed after 14 days. New replies are no longer allowed.