New OJS 3 Theme on Bootstrap 4

bootstrap
ojs
jats
theme
ojs3

#63

I suppose, this is index page for multijournal installation and I haven’t styled it yet (it is first in my TODO list). If you are hande with front-end development, you can modify this page by copy this file: https://github.com/pkp/ojs/blob/master/templates/frontend/pages/indexSite.tpl into the theme plugin’s correspondend directory: https://github.com/Vitaliy-1/oldGregg/tree/master/templates/frontend/pages

For styling it is better to create new CSS file here: https://github.com/Vitaliy-1/oldGregg/tree/master/css and point the path to it in the main PHP file of the theme: https://github.com/Vitaliy-1/oldGregg/blob/master/OldGreggThemePlugin.inc.php#L70

For the footer, it is coded here: https://github.com/Vitaliy-1/oldGregg/blob/master/templates/frontend/components/footer.tpl
If you want to preserve the changes after each theme upgrade, it is better to use own child-theme: https://pkp.gitbooks.io/pkp-theming-guide/content/en/child-themes.html


#64

Dear @Vitaliy
I tried adding fontawesomes in footer, some appear and some did not.
http://jurnalbeta.ac.id


#65

I need more information on this. Can you share the code that you have tried to add and your OJS version. Also, do you use latest theme version?


#66

I don’t use the latest OldGregg, Ojs 3.1.0. Here the fontawesome codes which could not show up

   <a href="https://web.facebook.com/betajtm"><i class="fa fa-facebook" aria-hidden="true"></i></a>
    <a href="https://twitter.com/jurnalbeta"><i class="fa fa-twitter" aria-hidden="true"></i></a>
`<span class="fa fa-fa fa-file-text-o"></span>`

<span class="fa fa-map-marker"></span>
<span class="fa fa-university"></span>

The last two codes did work


#67

Did you check this code to be valid according to fontawesome v5?


#68

Thanks, it is solved. It is about the prefix fa, fab and fal
https://fontawesome.com/how-to-use/svg-with-js


#69

Hi Vitaliy,

I installed your theme in our website. The website is displaying correctly in Mozilla Firefox 59.0.3 and Google Chrome Version 66.0.3359.139. However, in Internet Explorer version 11.431.16299.0, the webpages are not displaying correctly. The article details are not displayed there fully. I see only title of the article. No other details. I thought it could be a problem with my website/web host. So, I checked your demo site through IE.
http://ojsdemo.e-medjournal.com/index.php/oldGregg/article/view/4. Same problem. I could not see full article details. Any solution? Thanks.


#70

Internet Explorer isn’t update for a long time. As I remember the last update was in 2013. But there was a lot of changes in front-end development from that time. So, of course some issues can arise.

I think we shouldn’t pay much attention on this browser as only minority of people use it. For example, according to w3schools: https://www.w3schools.com/browsers/default.asp only 3.9% of people are using Edge/IE.

You can open issue on GitHub’s theme plugin page with describing the problem. I will take a look in a free time.


#71

Hi… Sir, I am happy to get your info, but why I can’t install that theme?


#72

Check the release you installed with your Ojs version.


#73

Keep in mind that OJS version must be 3.1.1 and PHP version >=7.1


#74

Apologies: thank you already answered me in the other post

Hello @Vitaliy . In your example http://ojsdemo.e-medjournal.com/index.php/oldGregg/article/view/4

you show a fig un xml. Where you opload the fig1.png? in the submission procces or on an external server for figures?

Figure 1 Awesome figure title.

Another boring figure caption.

Regards


#75

Figure is simply attached to the XML galley through a dashboard.


#76

Hi.
Thanks for your great work.
Question: There is a problem with recaptcha v2. It request to agree with privacy terms but there is no option to do it. How can I fix it?

Regards,


#77

Replied here: "You must agree to the terms of the privacy statement" Cant be seen on Registration page


#78

Hi @Vitaliy,
Is there a way to force a new line (or break) in the table head cell?

Best regards,


#79

You can put content into paragraphs.


#80

I think p tags are not identified or they are cleared. I do not get the following working. They appear in a single row.

<td><p>content 1</p><p>content 2</p></td>
or
<th><p>content 1</p><p>content 2</p></th>

Best regards,


#81

You can add them manually, most important that they are supported by JATS Parser.
Think, putting these lines into the p tag will be enough: https://github.com/Vitaliy-1/oldGregg/blob/master/templates/frontend/parser/table.tpl#L64-L68


#82

I made three changes:

1. Added last 4 lines in somewhere beginning of text.tpl

{strip}
    {foreach from=$parContent->getType() item=textType key=k}
        {if $textType === "bold"}
            <strong>
        {elseif $textType === "italic"}
            <em>
        {elseif $textType === "sup"}
            <sup>
		{elseif $textType === "br"}
            <br />
		{elseif $textType === "p"}
            <p>
2. Added last two lines towards the end of text.tpl

{foreach from=$parContent->getType() item=textType key=k}
        {if $textType === "bold"}
            </strong>
        {elseif $textType === "italic"}
            </em>
        {elseif $textType === "sup"}
            </sup>
        {elseif $textType === "sub"}
            </sub>
		{elseif $textType === "p"}
            </p>
3. Added last two items in Text.inc.php

private static $nodeCheck = array("bold", "italic", "sup", "sub", "xref", "underline", "monospace", "ext-link", "br", "p");

Still, I am not getting support for br or p in table cell.

Should I do something more?

Best regards,