Missing DOI in OAI export in multi journal environment

For a while now, we don’t know exactly since when, the DOI is missing in the OAI export. But only when we use the URL with /index/oai?verb=ListRecords&metadataPrefix=oai_dc&set=journalname.
When using /journalname/oai?verb=ListRecords&metadataPrefix=oai_dc&set=journalname it does go well. But this is not an option because only the general (/index/) is called by OCLC’s digital collection gateway harvester.
How can we solve this?
This is on our OJS 3.2.0-3 environment, but we have the same thing on our test environment where we are running 3.3.0-6.

Best regards,

1 Like

Looks like a redirection issue.

Is a common doubt that could be tricky because it need to be set according to your base_url variableS.

In this forum you have plenty of posts talking about this.
Search a little, try by your own and if you can’t fix it, I will help you on Monday.


Isn’t it strange that only the DOI does not appear when using /index /oai?ve…
The other values do. For now I searched for base_url settings but didn’t find the solution. Can you please help?

Best regards,

this is what I mean:
Missing DOI in OAI

Is there anyone who can help us with this item? The issue still exists.

OAI-PMH issues (multi-journal installation, multi-language) seems to describe the same issue.
This will be fixed by ImportExportPlugins do not export PubIds via ScheduledTaskTool · Issue #7194 · pkp/pkp-lib · GitHub ?

Maybe the description above provides some additional guidance on the solution direction?

In our test-environment OJS 3.3.0-8 is installed. The issue still remains.

How can we fix this?

The issue also occurs on your demojournal.
When we use this URL:
The DOI appears.
When using https://demo.publicknowledgeproject.org/ojs3/demo/index.php/index/oai?verb=ListRecords&metadataPrefix=oai_dc
All fields except the DOI appear.

Is there a way to fix this?