JS Error in OJS 3.1.1

We have problems with the submissions screen in OJS 3.1.1 on a site upgraded from 3.1.0. It is blank for all 4 submissions tabs (My Queue, All active, etc). There are no server errors, and all requests have status 200, but JS crashes with the following:

TypeError: Cannot read property 'manager' of undefined
at Object.userHasRole (build.js:1)
at Le.currentUserCanFilter (build.js:1)
at ma.get (build.js:6)
at ma.evaluate (build.js:6)
at Le.currentUserCanFilter (build.js:1)
at Le.render (build.js:6)
at Le.t._render (build.js:6)
at Le.r (build.js:1)
at ma.get (build.js:6)
at new ma (build.js:6)
rt @ build.js:1
nt @ build.js:1
et @ build.js:1
t._render @ build.js:6
r @ build.js:1
ma.get @ build.js:6
ma @ build.js:6
At @ build.js:1
Le.$mount @ build.js:6
Le.$mount @ build.js:6
t._init @ build.js:6
Le @ build.js:1
init @ build.js:1
(anonymous) @ submissions:153

We also occasionally get the error here: Error in upgrading OJS 3.0.2 to OJS 3.1.1, on the same screen, not sure if it is related (##api.submissions.unknownError##). Did not have this problem in 3.1.0.


Hi @simonmitternacht,

Is it possible that your browser still has the old JS cached? Try hard-flushing your browser’s cache, or try another browser.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,
I get the same error when I disable cache in Chrome, and from what I can tell a fresh copy of build.js is being fetched. Is there a build step for JS that I have missed?


I am having the same issue with the latest OJS, all the 4 tabs are empty

Hi @adilhk,

Have you tried the remedy suggested above?

Alec Smecher
Public Knowledge Project Team

yes, thanks for all the help

Turns out the problem was I didn’t run npm install and npm run build. Was reading docs/README and docs/UPGRADE, not README.md