How change publication date?

Hi @israel.cefrin,
This is issue 1 in OJS 3.1. If I choose a publication date that has already been used from the dropdown menu (whether in the past or future), I have to hit enter in the window before saving otherwise today’s date will be used instead. This is not the case for e.g. the copyright year in the same window where choosing a year from the menu is saved when you click save - instead if you hit enter after choosing a year here, the window closes.


Hi @israel.cefrin,
so this is issue 2: 16
This is a manuscript that has gone through the normal process (not Quicksubmit) and is then assigned to an issue. The publication date cannot be set in this window. Instead, today’s date is automatically added as the publication date although the manuscript may have been published previously as a preprint or may only be scheduled for the next issue to be published next month. When the window is called up a second time after closing it, the window publication date appears and can be altered - but only if it is confirmed by hitting enter.
Hope that makes it more clear. Thanks for your help.

Hi Israel, hi all -
we just came across a similar issue. An article was added in February this year to an issue published in 2018. In the “How to Cite” box the article is now shown with the wrong year (2019 - when it was published, not 2018, the year of the issue).
I hesitate to back-date the publication to, say, December 31st 2018 - that is not when it came out. But if I want the How To Cite to display the correct year, I will have to, no?
Cheers for any tips,

Hi @ahacker

The "How to Cite " box will show the date of artcle not the issue. It relies on the case when you have a continuous publishing stream and it keeps the article history then.


Dear @israel.cefrin ,

I have a problem that I cannot assign the publication date to the oldest one.
For example, I have uploaded & published a back issue year 2008 in 2016 (with publication date remain blank) Screenshot attached. But later I found that the paper could not be assigned to a specific year (2008). How can we fix this matter? I’m using OJS I’m sorry posted under OJS 3 section.



Hi @israel.cefrin,
I was also looking into this, but I could not find the “Schedule for publication” button you were mentioning. After I click on "Production (tab), I don’t see it, in fact.
Am I missing something? I attach a screenshot about this.
Best regards


Hi @budhi

This is a reasonable outdated OJS version. The latest OJS 2.x is 2.4.8-5 (May, 2019). However, I think that you could try to unpublish the issue and try to add this other article to it. Then, re-publish it keeping the original date.

Please, let me know whether it works for you. Also, make a backup of your database.


Hi @leonardo.mancini

I’m not sure whether I’ve understood your question. Did you run through all stages in submission workflow, however, at end you can’t publish your article?

Have you set it on a existing Issue for publication? Has this article been passed for reviewing, copyediting and else?


Hi @israel.cefrin,

sorry, I try to reformulate better my answer.
Since I created a website for an old journal, I have inserted all the articles using the QuickSubmit issues.
Now, I manage to edit the issues date, but not the article publication date. I don’t find, under the “Submissions” panel, where to edit this info, which appears to not editable in fact.
Would you have an idea, for how to do that? At the moment, I have issues of the eighties, with articles which are said on the website to be published on 30 January 2020 :slight_smile:
But on that date I simply uploaded them on the new open-access website. The author wrote it and published thirty years ago.
Thank you for your attention and patience.
Best regards

Hi @israel.cefrin,
I have found it! I couldn’t see the water in the river apparently!
All the best,

1 Like

Hi @leonardo.mancini

Could you post the solution to your question? Maybe other users can take advantage from the very same approach to similar issues they face.


I know you did not ask me, but for the same scenario we first make sure that the issue publication dates are ok, and then run the script below.


# Journal id to consider
$journal_id = "54";

$mysqli = new mysqli('SERVERNAME', 'USERNAME', 'PASSWORD', 'DATABASE');

$sql = "SELECT issue_id, date_published FROM issues WHERE journal_id='$journal_id'";
$result = $mysqli->query($sql);

while ($issue = $result->fetch_assoc()) {

    $issue_id = (int) $issue['issue_id'];
	$date = $issue['date_published'];

    print "Issue id: " . $issue_id . " Date: " . $date . "<br />\n";

    $mysqli->query("UPDATE `published_submissions` SET date_published='$date' WHERE issue_id='$issue_id'");



Note that this script will not work with OJS 3.2 when it is published!

Hi @israel.cefrin, hi @ajnyga,

wow, this is interesting and useful.
I made it in a very more banal way (I suspect, too banal, that’s why I didn’t comment any further).
The date of publication, editable, of each article appears in the “Schedule for publication” tab (the blue button which appears in the right sidebar at the very last step of the publication process). I attach here a screenshot. I changed all of them one by one entering in each article.
@ajnyga, with the script you sent, you would run it each time for each issue published, is that right?

All the best,



Yes, you could do that. It just stamps the issue pubdate to the attached articles. Of course it does so to all published articles in that journal, but if the issue pubdate has not changed that should not matter.

this seems to have been fixed, see:

@budhi here’s a workaround:

1 Like

Dear @fgnievinski thank you for the solution. :+1:

1 Like

Are there the same script for OJS 3.2.1 version?

dear iseael.Petrus
I am using OJS 3.1.14 version. now I as editor of medical journal facing problem in sending emails to reviewers and authors for communication. when i send review to reviwer my screen shows that it has been sent and i am notified but on confrming on phone they are informing me that they did not receive any type of email from ojs. i checked my setting of journal and found that my emails disabled. i want to enable them but not able to successfully do it. kindly guid me cocerning this issue for smooth handling of ojs.
Dr Shireen

Hi @shireen

I’ve answered you in the other post, could you please check it?