Font awesome icon doesn't showing in ojs

font awesome icon doesn’t showing in ojs

https://jcpsp.pk/ojs-jcpsp

Hi @Zahid_Ali

Could you write what you did to implement font awesome and/or some log error message?
It may help other users to undersand your issue and even give possible fixes.

Regards,
Israel Cefrin
Public Knowledge Project Team

1 Like

Hi,
I tried using font awesome in footer
image

But the icons do not show up
How to solve this?

would you try with
fab fa-facebook

or
fas fa-facebook

It does not work.
@israel.cefrin

how are you including font awesome into your project?

Hi @josuevalrob
I place the codes in footer page in settings/website

try tu put the CDN in the header… https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css

script src=“https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css”></script
I tried it at custom tags but nothing changes
I also tried link href="//netdna.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.min.css" rel=“stylesheet” in html but It just disappear

Maybe this can be helpful:

Sorry, to make sure what I understand. Do the codes below place in .htaccess somewhere?

Header set Access-Control-Allow-Origin “*”

Here in details what I have

I customize the footer using html page. The codes below just disappeared when save with two list symbols remain without awesome font displayed in the page

image

yes, you have to put it in file
.htaccess

I have put them but nothing changes
image

I added the codes image
to html page in footer. It just shows list icon

image

I have this in .htaccess and it works:
<<FilesMatch "\.(ttf|ttc|otf|eot|woff)$"> <IfModule mod_headers> Header set Access-Control-Allow-Origin "*" </IfModule> </FilesMatch>

With your codes, I have the error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@jurnalbeta.jurnalbeta.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

You have to ask your hosting company why they are so restrictive and their over-restrictive approach does not allow those fonts to appear. However, you can remove my code, but also please ask your hosting company to enable fonts to appear since, it seems to me, they do have systemic settings of restrictions which disable fonts to appear.
The code I gave you allows fonts to be seen and actually the code asked server to do that but server could not due to teh system-wise restrictios of hosting company.
Good luck in communication with guys who set up apache on server.

Would you mind share your web to take a look such fonts displayed?

Hi @kawahyu,

I have used the following codes in my template and got the following icon.

<i class="fas fa-chart-bar fa-lg"></i>

image

If you are using manuscript-Jats by @Vitaliy, he may comment on your problem.

Regards,

Font-awesome is uploaded inside oldGregg theme and is situated here: .../oldGregg/js/fontawesome-all.min.js
It is the latest version. You can use it as usual: Font Awesome

is it possible to add fontawesome-all.min.js file to manuscript-jats theme?