Failed Ajax request or invalid JSON returned while adding new user "Add User"

Hello Everyone,

I have the same error while I am trying to “Add new User”. I have installed OJS 3.2.0, everything works fine except this while new user creation. Please help I am stuck with this issue.

This is the error log file what it shows.

[25-Mar-2020 05:36:45 UTC] PHP Fatal error: Uncaught Error: Call to undefined function bindtextdomain() in /home/wumkpdcedu/
Stack trace:
#0 /home/wumkpdcedu/ Sokil\IsoCodes\AbstractDatabase->bindGettextDomain()
#1 /home/wumkpdcedu/ Sokil\IsoCodes\AbstractDatabase->__construct(NULL)
#2 /home/wumkpdcedu/ Sokil\IsoCodes\IsoCodesFactory->getCountries()
#3 /home/wumkpdcedu/ UserDetailsForm->display(Object(Request))
#4 /home/wumkpdcedu/ UserGridHandler->editUser(Array, Object(Request))
#5 /home/wumkpdcedu/ in /home/wumkpdcedu/ on line 87

Best Regards

Hi @pjhssr,

See e.g. The 500 error in registration page - #3 by littlemeizhi

Alec Smecher
Public Knowledge Project Team

Yup I checked and tried but still not succeed…image

Hi @pjhssr,

Can you clarify what you tried?

Alec Smecher
Public Knowledge Project Team

I am trying to add a new user “Add User” for each journal a separate user and that user can be a Reviewer, Author, Journal Manager, Journal Editor, Indexer etc it shows me the same error 6986d2ccc3ac6584c12055a174bcd9a4e725d585_2_690x257

Hi @pjhssr,

I’m referring to the suggestion at the thread I linked above. Did you try that solution? If so, what specifically did you try?

Alec Smecher
Public Knowledge Project Team

I have the same issue when I try to edit an reviewer’s overdue date.
PHP getttext extension installed and enabled. In this case I don’t have access to logs.

Hi @spotter-ssol,

You will definitely need access to the PHP error log, and an ISP should always provide you with access to those. Otherwise it’ll be very difficult to manage any kind of PHP-based service.

Alec Smecher
Public Knowledge Project Team

Problem solved. Cause was unpropper file/dir ownership and permissions.


Hi @spotter-ssol
Which specific file or folder was causing this?
I am facing similar issues but cannot identify which file or folder’s permission I need to change.


just set user and group to apache for all files and folders recursively.

Hello all,

have you tried to upgrade the php version on the journal hosting domain you manage? I experienced the same problem when my php domain version was still using the previous version, and this problem was resolved when the php version on my cpanel domain hosting was updated.

so hopefully it can help others if experiencing the same problem…

This topic was automatically closed after 13 days. New replies are no longer allowed.