Failed Ajax request or invalid JSON error with quickSubmit plugin Add Contributor

Thank you very much for your response. Yes, my mistake! The install is in latest version, 3308. I

have restored the site via backup to a point where everything is working again so far. The problem appears to have been the uploading of the AuthorRequirements plugin (which I really, really need, as several of our back issues are student efforts with up to 10 authors listed).

I have not been able to install any plugins via the Plugin Gallery. All I get is a popup window stating this plugin has not yet been installed and showing the git-hub link to the plugin page. No button or other prompt is displayed to install a new plugin in either tab. My user role is Journal Mgr. What is the correct procedure in such a case?

Many thanks in advance.

Hi @soj,

Thanks for clarifying. Where did you locate the Author Requirements plugin from - can you send a link?

And for the error message that you see when using the plugin gallery, can you post a screenshot of this so I can get a better sense of what’s happening?

PKP Team

Here is the link, which is provided in the info popup when I click the plugin in the Plugin Gallery.

No error message presents itself overtly in the Plugin Section. I have debug mode enabled in the config file. Simply there is no way given to install any plugin from the Plugin Gallery. I have provided a screen shot. I believe there should an install tab next to the search field? It is not displayed in either of the Plugin Section pages.

Screenshot 2021-09-15 125138

Hi @soj,

Thanks for providing these details - this is helpful. You say that you only have journal manager privileges? You might want to check with your site admin to see if they can install / upgrade the plugins? If they’re not seeing any options that could point to a larger problem. The author requirements should be in the plugin gallery - but if not I’m not sure… :thinking: - but will see if there are some other options.

PKP Team

And here I was believing the JM has admin privileges.

Is it still not possible to create a second admin except via a DB edit?

The admin sees the upload option on the installed plugins page only.
From here I imagine I can research the manual for further instructions.

Many thanks.

I am currently logged in as Admin. When attempting to add a plugin or upgrade one the system returns this error:
The current role does not have access to this operation.
I can get to the install popup window of plugins are showing in the plugin gallery, but nothing happens when I click OK in the “Are you Sure?” window. It just hangs …

Hi @soj,

Hmmm… if it hangs that might be pointing to another issue going on. Do you have access to your PHP error logs and are able to check for relevant errors there?

PKP Team

Here’s the thing. Under the erroneous assumption that JM’s have admin rights like they did in our original install, I created the journal as a JM (at least I think I did). I wonder if the Admin account needs to be added as a user?
At any rate, currently the admin does not appear in the journal user list. Is there a way to add the account?

Hi @soj,

That seems unlikely, as only site admins can create new journals. It’s possible that you cannot see the admin in the journal list. There is an option to search for users that are not affiliated with a given journal - it’s a checkbox next to the search for users. If it is a separate account you’d have to login with that account. You should at least be able to see what email is associated with the account, I would think, and could possibly reset the password if you have access to that email?

PKP Team

I can log in to the ADMIN account no problem.
The problem is the Admin seems to have no permissions to do anything in the journal.
I need to install these plugins, and it takes an admin to install them, but trying to do so as admin returns “The current role does not have access to this operation,” plus another message “undefined”, as soon as I try to access the journal setting wizard.

I HUGELY appreciate your responses. I don’t know why I’m having such a hard time. I look at the screen images in the documentation and my install looks so different. I’ve lost a whole work week on these issues. I sent a form email to the PKP purchased support service with some questions specific to my situation days ago, and no one ever even responded.

I have found the admin user by searching unaffliliated users. I edited the admin user (adding JM role) and now it shows up in the journal.

However, trying to access plugins, the first tab just spins. The first tab (installed plugins) is needed in order to access the QuickSubmit plugin. It used to show up in Tools, but doesn’t any more. Time to check error msgs.

[14-Sep-2021 17:16:58 UTC] PHP Deprecated: Non-static method Core::removeBaseUrl() should not be called statically in …/ojs/plugins/generic/usageStats/ on line 777
[14-Sep-2021 17:16:58 UTC] PHP Deprecated: Non-static method Core::_getBaseUrlAndPath() should not be called statically in …/ojs/lib/pkp/classes/core/ on line 231

I should add plugins tab one spins, regardless of user logged in. The second tab (gallery) does open.

Hi @soj,

Thanks for the follow-up.

Please note that the PKP|PS service does not directly answer questions of non-hosted clients - that’s what we do here on the forum. Although, if you were interested in hosting services with them, I would encourage you to follow-up with them and make that clear.

With respect to this issue of the hanging and spinning. I’m not entirely sure what’s happening here - those errors may provide some indication, so I’m going to see if some of my colleagues can weigh in on what they think might be causing this issue when they are available, so stay tuned.

PKP Team

Thanks. Really hoping you all can help. Not much else I can do. We won’t be hosting with PKP - can’t afford it.

I have the same problem here. Fresh install of OJS (testing website). OJS version: (upgraded from PHP: 7.3.29. Database server: 5.5.5-10.2.40-MariaDB.

Steps I took:
Installed Author Requirements plugin through plugin gallery. Disabling it did not solve the problem.
Error log:

[Tue Sep 21 00:15:02.403122 2021] [fcgid:warn] [pid 5119] [client] mod_fcgid: stderr: PHP Fatal error:  Uncaught Error: Call to a member function getData() on null in /home/ojs/public_html/cache/t_compile/502a3c7e2e32fa61fb30b380b67fb26018d497e4^, referer:
[Tue Sep 21 00:15:02.403130 2021] [fcgid:warn] [pid 5119] [client] mod_fcgid: stderr: Stack trace:, referer:
[Tue Sep 21 00:15:02.403132 2021] [fcgid:warn] [pid 5119] [client] mod_fcgid: stderr: #0 /home/ojs/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_6148d3380d6809_61967764(Object(Smarty_Internal_Template)), referer:
[Tue Sep 21 00:15:02.403135 2021] [fcgid:warn] [pid 5119] [client] mod_fcgid: stderr: #1 /home/ojs/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Internal_Template)), referer:
[Tue Sep 21 00:15:02.403137 2021] [fcgid:warn] [pid 5119] [client] mod_fcgid: stderr: #2 /home/ojs/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_template.php(216): Smarty_Template_Compiled->render(Object(Smarty_Internal_Template)), referer:
[Tue Sep 21 00:15:02.403139 2021] [fcgid:warn] [pid 5119] [client] mod_fcgid: stderr: #3 /home/ojs/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(232): Smarty_Internal_Template->render(false, 0), referer:
[Tue Sep 21 00:15:02.403142 2021] [fcgid:warn] [pid 5119] [client] mod_fcgid: stderr: #4 /home/ojs/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smart in /home/ojs/public_html/cache/t_compile/502a3c7e2e32fa61fb30b380b67fb26018d497e4^ on line 36, referer:

Is there a version of OJS where the QuickSubmit and Author Requirements Plugins actually work with no problems. Getting no where here with a fix, so I am looking at a fresh install.


I have the same problem. Did you solve it? How you did it?

Kind Regards,

Hi there, I’m having the same problem after update to

Quicksubmit and Author Requirements plugins updated from Plugin Gallery.

Php version: 7.4.22.

I did a completely fresh install, but I wasn’t too far along regarding content. So far, so good. EE

Did you fresh install only OJS or PHP, etc?
Do you think that if I upgrade the OJS version could work?

Hi, I just made a fresh install and discovered a clue where the problem could be. That “Failed Ajax request or invalid JSON error” appears after the upgrade of the Author Requirements plugin. But it doesn’t disappear after deleting that plugin, neither after deleting the QuickSubmit and installing it again.

So, in order to work fine again, I made a fresh install, upgraded QuickSubmit, but NOT upgraded Author Requirements, and worked fine.

I think it has something to do with the Author Requirements plugin, not working well with the last ojs version,


So here is my weird twist:

Attempting to add a Contributor in the QuickSubmit Form after enabling email optional in AuthorRequirements Plugin settings caused a “Failed Ajax request or invalid JSON error” (OJS V3.3.0.8 ).

I had not upgraded the plugin.

Having nothing left to loose, I upgraded the plugin, and now the Add Contributor seems to work again.