Did not send any mail

hi
I config all things relate to mail configuration SMTP…etc, it has worked as well but today I see the new error when I send email to my users and appear an error: There was a problem sending an email message. Please try again later, or contact your system administrator.
now any email did not send.
please help me.

Hi @koorosh_farshid,

Could you please confirm which software and what version you are using? As well, have you made any recent changes on your site?

Kind Regards,
Patricia M.
Public Knowledge Project Team

thank you for replay
OJS Current version: 3.1.2.0 (May 4, 2019 - 11:16 AM)
I didn’t change my site

Capture

i try reinstall OJS 3 in another host but I still had this problem
i capture smtp config
gmail%20smtp

Hi,

You need to uncomment some of the configuration options to enable this config. See this example:

config_inc_php_-_josekarvalho_net

By using your configuration with comments, the server is using sendmail so send emails and not your configuration.

Regards,

José Carvalho

One of my client facing same error since 4 days. I have check every aspects on smtp setting, but no luck. Please help us.

Error - There was a problem sending an email message. Please try again later, or contact your system administrator.

Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
; smtp_server = mail.domain.com
; smtp_port = 587

; Enable SMTP authentication
; Supported mechanisms: ssl, tls
; smtp_auth = ssl
; smtp_username = emaill.account
; smtp_password = Pass

Configuring the System to use Gmail SMTP

To use Gmail SMTP to send email from OJS, you can use the following settings in
config.inc.php.

For OJS 2.x:

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = "ssl://smtp.gmail.com"
smtp_port = 465

; Enable SMTP authentication
smtp_auth = SSL
smtp_username = "user@gmail.com"
smtp_password = "password"

For OJS 3.x:

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = smtp.gmail.com
smtp_port = 465

; Enable SMTP authentication
smtp_auth = ssl
smtp_username = “user@gmail.com
smtp_password = “password”