Can not create a revision of an existing document. HTTP Error

Hi
I’m running OJS 3.2.1.4.
Problem Description:
When uploading a file for a revision if you select that you are uploading a revision of an existing file then proceed to upload a file you will get a “HTTP Error”. This does not happen if you select “This is not a revision of an existing file”. I can reproduce the error no matter which type of user is logged in and it doesn’t matter who the original up-loader is. The error in the error log is:

PHP Fatal error:  Uncaught Error: Call to a member function getSubmissionId() on null in /var/www/sites/jchla/lib/pkp/classes/submission/SubmissionFileDAO.inc.php:456
Stack trace:
#0 /var/www/sites/jchla/lib/pkp/controllers/wizard/fileUpload/PKPFileUploadWizardHandler.inc.php(422): SubmissionFileDAO->assignRevisionToReviewRound(79497, 8, NULL)
#1 /var/www/sites/jchla/controllers/wizard/fileUpload/FileUploadWizardHandler.inc.php(31): PKPFileUploadWizardHandler->_attachEntities(Object(SubmissionFile))
#2 /var/www/sites/jchla/lib/pkp/controllers/wizard/fileUpload/PKPFileUploadWizardHandler.inc.php(375): FileUploadWizardHandler->_attachEntities(Object(SubmissionFile))
#3 /var/www/sites/jchla/lib/pkp/classes/core/PKPRouter.inc.php(391): PKPFileUploadWizardHandler->uploadFile(Array, Object(Request))
#4 /var/www/sites/jchla/lib/pkp/classes/core/PKPComponentRouter.inc.php(257): PKPRouter->_authorizeInitializeAndCallRequest(Array, Object(Request), Array)
#5 /var/www/sites/jchla/lib/pkp/classes/core/Dispatcher.inc.php(143): PKPComponent in /var/www/sites/jchla/lib/pkp/classes/submission/SubmissionFileDAO.inc.php on line 456

Another important aspect is even with the error the history of the original file is updated and the physical file does get uploaded onto the server but it’s does not appear in the interface.

Also note the same error is in this post:

Here is a screen shot of the problem:
image

Hi, I had the same problem and after the feedback from Nate, in my case, was solved by applying this commit.

1 Like

Thanks. We are upgrading to 3.3 soon so I suppose that fix will be included.

1 Like