Api submission Uknown Error

I try to manage the submission of my journal but it looks like something trouble and difficult to access the article. Then this information “##api.submissions.unknownError##” displayed on my screen. Could you help me please?
i checked many topic due to this problem so i send more information for detals:
when i got this error in my console browser show this errors too:
TypeError: b is undefined[Learn More] pkp.min.js:315:449
a.pkp.controllers.modal.ModalHandler.prototype.modalOpen http://ojs3./js/pkp.min.js:315:449
e.a.methods.ajaxErrorCallback http://ojs3.
bound self-hosted
e.a.methods.get/<.error http://ojs3./js/build.js:1:46188
n.Callbacks/j http://ojs3.
n.Callbacks/k.fireWith http://ojs3./lib/pkp/lib/components/jquery/jquery.min.js:2:27949
x http://ojs3.

my Php server version : 5.6.32-1+0~20171027135529.7+stretch~1.gbpd60169

and my config charset is like this:

; Default locale
locale = fa_IR

; Client output/input character set
client_charset = utf-8

; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = utf8

; Database storage character set
; Must be set to “Off” if not supported by the database server
database_charset = utf8

; Enable character normalization to utf-8 (recommended)
; If disabled, strings will be passed through in their native encoding
; Note that client_charset and database collation must be set
; to “utf-8” for this to work, as characters are stored in utf-8
charset_normalization = On

I should say that when i changed client_charset = utf-8 to client_charset = utf8 all persian translations not working and OJS return just key of message not translate message

thanks in advance

Hi @mbabaei,

What exact version of OJS are you using?
Is this an error that appears consistently, or only sometimes?
Have you recently upgraded, and if so, is that when the problem started?

Alec Smecher
Public Knowledge Project Team

i should add some more information:
My ojs version is
and i know that there is one update for this version but i couldn’t upgrade for now
in fact , its appears only some times
and there is very strange note on my problem,that problem just occurred when i work with Firefox , chrome never shows this error

Could that be the same problem as here: [Solved] Custom domain error ##api.submissions.unkownError## on OJS3.1.1 - #9 by paul ?

i never set such configuration for each of journals, just set base_url as main domain

hi guys
i found when i click on “New Submission” button above error occurred,
the url of that is : http://ojs/index.php/mls/submission/wizard

how can i solve that?

@mbabaei, how did you install – using the release package from here https://pkp.sfu.ca/ojs/ojs_download/, or somehow differently?

1 Like

Today we faced with the same problem after upgrade of our production OJS to
We are using the following config: Linux, PHP 7.0.29, Apache 2.2.22, mysql 5.5.60. The upgrade itself went absolutely without problems. Generally everything is working properly, except Submission section.

I see only strange errors in php error log:
[error] ojs2: 404 Not Found, referer: https://biocomm.spbu.ru/submissions
[error] ojs2: 404 Not Found, referer: https://biocomm.spbu.ru/submissions

Here is a picture of these moments in browser console:

I was forced to roll back because OJS is needed for work now…

@bozana i downloaded and installed Ojs from your given link

@rkhalikov, do you maybe have any redirects set for your installation? – For example, I do not see the journal path in the URL from the error log…
s. for example [Solved] Custom domain error ##api.submissions.unkownError## on OJS3.1.1 - #12 by paul

Well, the main question is why does this problem come up right now? We use OJS for a year and a half, changed three versions, changing nothing in the settings of the journals. But only now and only in submissions section the problem get out… I tried the latest several hours ago, absolutely clean, even without public, etc. data - just our config.inc.php and cli command for upgrade. Upgrade - done, api errors - exactly the same…

We have several journals within our OJS. Thus we use redirects to “isolate” journals in their own domains. Here are the corresponding sections in config.inc.php and .htaccess:

base_url = "https://vestnik-journals.spbu.ru"
base_url[index] = https://vestnik-journals.spbu.ru/index
base_url[s3] = https://biocomm.spbu.ru

## biocomm has its own domain
RewriteCond %{SERVER_NAME} ^(www\.)?biocomm.spbu.ru
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ /index.php/s3/$1 [QSA,L]

I repeat that after upgrading, the api error appears in all the journals and only in the submissions section. The same settings in version do not cause any errors, everything in submissions works properly.

Can you try the solution suggested in this thread and let me know if that solves the problem for you? [Solved] Custom domain error ##api.submissions.unkownError## on OJS3.1.1 - #12 by paul

OK, here is our result. First of all, I added a line for one journal (biocomm) in the current installation and checked that it does not affect anything:

## biocomm has its own domain
RewriteCond %{SERVER_NAME} ^(www\.)?biocomm.spbu.ru
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} !api/v1/
RewriteRule ^(.*)$ /index.php/s3/$1 [QSA,L]

Next, I upgraded to and made sure that there was no api error for biocomm journal, whereas for everyone else there was. Then I added this line for all other journals - now they are working properly in terms of submissions section.
The question remains - is this a workaround or is it going to be like this all the time?

Thanks for reporting back @rkhalikov. We’ve identified the source of the issue (I think) and filed a bug:

When this is fixed, you shouldn’t need the workaround in your htaccess file.