You dont have enough space in user directory

Hi to all! I am using OJS 3.2.1.2 and I am experimenting problems about uploading images in different journals. So, I will explain the details:
When I am trying to upload a image in the “Author Guidelines”, I am receiving the following message:
uploadSize
I found in another posts that I have to change the “public_user_dir_size” variable in config.inc.php. I did not found that variable there but I found it in config.TEMPLATE.inc.php. I changed that value several times but nothing happen. Should I need to restart to apply the changes? Am I changing the wrong value?
Thank you!

Hi @elementslive

If that variable is not in your config.inc.php file you’ll need to add it to the file, in the correct section. OJS does not load any configuration settings out of the TEMPLATE file.

Best,
Jason

1 Like

Hello all …

I have the same problem as the OP … but I detected it when trying to upload images to custom blocks… after upgrading to 3.3.0.5

my config.inc.php does have the line:
public_user_dir_size = 5000

The problem does not happen if I upload the images as the site admin user, but for any other other user…

No error is reported at the webserver logs related to this either.

@hilongo

5000 is a small amount for the max upload size. Have you tried to increase it? The number is in bytes, so 5000 is only 5Mb.

Best
Jason

1 Like

@jnugent thanks for the tip … indeed, changing the value to 50000 solved the problem for me.

Thanks a lot!

2 Likes

I tried adding the variable in config.inc.php and it worked. If someone doesn´t know where is the correct section, you have to put it in “File Settings”. Thank you!

1 Like