Wrong language of an article displayed in TOC of an issue


This is my first post, so first thanks to all who contributed to OJS!

Recently we decided to use OJS to put our journal online. Everything works perfectly fine so far, except one small detail. The articles published in our journal are mostly in Polish, but quite a few of them are in English. The website, however, is bilingual with metadata provided in both languages. It would be great, if one can tell by the table of contents whether a specific article is in Polish or English, as it is in other bilingual implementation of OJS.

Nevertheless, it seems that the settings in “indexing” part of submission metadata do not take any effect.

Can anyone tell me what do I do wrong here? Probably, something very basic is missing.

1 Like

Hi @p_urbanczyk,

I think the language displayed in TOC is the galley language i.e. when editing a galley you can check/determine the language.



Thank you, @bozana, that was it!


As @p_urbanczyk, we have a multilingual journal, too. In our case, we have four locales, and articles and metadata in three of those languages. Articles are only edited in the submitted language (just one file/language by article, I mean).

Our journal’s table of contents appears to be okey, but it seems there is a somehow contradictory information between the language settings in different fields. Take this Spanish-written article as an example:

a) In the ‘Galley’ form, the language setting is Spanish (es).

b) But in the ‘Metadata’ view, the language setting is English (en) [!!!].

If this were a problem, how could we correct it, @bozana?

By the way, I agree with @primozs (http://forum.pkp.sfu.ca/t/ojs-language-in-multilingual-journals/1037?u=ankulegi) in considering the ‘double language setting’ a bit confusing. It would be great if future versions of OJS could clarify it a bit (as far as the manual is concerning, at least).

Our examples show that language setting in OJS is not doubled but tripled - in step 1. and 3. of the submission as well as in the article galley (the last one, however, can be edited by the editor only). No wonder why it is a bit confusing.
Anyway, all those settings can be changed manually and I guess you need to do so, if you want to preserve the consistency among the languages displayed in TOC and metadata. In the case you’ve shown above just type “es” instead of “en” and click “Save Metadata” at the bottom of the page.

1 Like

Hi @ankulegi,

Yes, you will have to manually set the correct language in that metadata field.


1 Like

Thank you very much, @p_urbanczyk and @bozana!

I thought the ‘Language’ field in the ‘Metadata’ section referred to the keywords above, not to the hole article. What a misunderstanding!! :sweat_smile: