Why I can't see options with User Admin?

Hi, i’m new with this software. I have many questions, but first I want to know why I can’t see more options as admin like settings or another options. Please, help me.

Hi @Steven77dev,

I suspect you’ll find what you’re looking for once you create a journal under “Revistas Alojadas”.

Alec Smecher
Public Knowledge Project Team

I will do and tell you. Thanks

I want to close. I can see options now.

Hi, I am facing the same problem as described in the first post. I upgraded an OJS installation that contains one journal, named JMS, from ver 2.4.8 to ver 3.0.2. The upgrade was successful and the site seems to work perfectly with almost all of the functionality working. And then I go to dashboard as admin and what showed up is the same like the screenshot in the first post, i.e. there is only one menu --administration.

I tried to log in with another user with journal manager role and wanted to assign journal manager role to admin, but user admin is not listed in the users menu of the journal.

Then I found this post and I tried @asmecher suggestion to create new journal, I named it TEST. After creating TEST journal, the menus showed up just like what journal managers have plus administration menu. But when I switched back to JMS journal, there is only administration menu just like before, i.e. the problem still exist.

Clicking settings wizard under JMS journal in hosted journals give me alert “The current role does not have access to this operation.”

And when I deleted the TEST journal, the “Site Settings” link (under Administration → Site Management) dissappeared. It should be exist under Hosted Journals link like before the TEST journal deleted. And if I try to visit the link to it e.g. /index.php/jms/admin/settings (which I can access before I deleted the TEST journal), the page redirects to /index.php/jms/user/authorizationDenied?message=user.authorization.accessDenied.

Obviously, creating dummy journal can be alternative solution since I can manage the site wide settings by login with admin account and I can manage the journal as well by login with journal manager account. But, I think there should be the right solution for this.

My guess is that the admin is not assigned to JMS journal. Then I tried to find in the database where to add the admin to JMS journal, but I found nothing.

I am very new to OJS, please guide me to solve this problem.

Thank you.

Solved my problem by adding the admin user to JMS journal manager group.
step 1: check user_id of the admin, the default is 1, just to make sure → select user_id from users where username=’{admin username}’;
step 2: check user_group_id of JMS journal manager group from table user_groups → select user_group_id from user_groups where role_id={journal manager role_id} and context_id={JMS journal_id};
step 3: add admin to JMS journal manager group → insert into user_user_groups (user_group_id, user_id) values ({user_group_id of JMS journal manager},{user_id of the admin user});

Hope this help someone facing similar problem.