Version 3.2 search bar malfunctioning

We have searchable PDFs on three sites and since upgrading to 3.2 the main search bar is malfunctioning. What happens is that a search produces no results and switches us to the page where advanced filters can be applied. When we search for the same word using the search page hits are successfully produced. After having searched using the search page if we then return to the main search bar it will (usually) find the same item. It therefore appears that the main search bar only finds content that has previously been found from the search page. However even this is sporadic. Sometime the main search bar returns no hits then upon trying a second time it succeeds. What is going on??

1 Like

Still no reply to this after one month in which all three sites I look after have lost search functionality from the main search bar. On one we tried rebuilding the indexing but it yielded no results. Besides, as the search page shown when there are no results works the indexing must be in place. It is just the top search bar that is not working.

Hi @nickpanes,

Are you able to provide me with the URL to the site and some instructions that can demonstrate the problem (even if intermittently)?

Alec Smecher
Public Knowledge Project Team

I used to have a similar issue, and it seems resolved after executing the following command:

Rebuild your search index with the command line tool:
php OjsInstallationDirectory/tools/rebuildSearchIndex.php

We tried that without success

1 Like