UsageStats problem

Weve problem with our UsageStats. On server wehave 5 catalogs:

usageEventLogs - here everyday we have 2 files: today and yesterdey LOG. (usage_events_20160210.log, usage_events_20160209.log)
stage - here we have 152 files…I think that`s error and our problem
processing - today one file of 18.01.2016
archive - 207 files - I think that is OK - I may to search these logs on table metrics (in the database OJS)
reject - with 6 files

Do you have an idea - what I must to do to complete the missing logs (on table metrics)?
Because the statistics for the missing days indicate 0 results…

Today usage_events_20160209.log moved to a folder "stage:…but in archive the last of 22.01.2016…

Hi @karwas,

It seems have problems moving files around the usage stats folders… Try this FAQ: My published file views or statistics reports shows no data. What do I do?

On top of that, which OJS version are you using? Check for a folder named scheduledTasksLog under your files directory, and if it exists, try opening the last file starting with the string "Usagestatisticsfileloadertask- ", it might tell you whats wrong.


We use OJS in 2.4.6.
I checked and I haven`t scheduledTaskLogs folder (look at attachment ojs3)
On the test version I heve this folder (look at attachment ojs1)
I wrote to my administrator. Maybe change permissions on server.


I checked and rebooted the server.
We havent scheduledTaskLogs folder on our server.
Nobody modify folders permission.
Nobody modify base_url setting inside my file.

Here is our config.php:
Where is the problem?


Can You help me?


Sorry the long time for answering. There is something not working in the installation that’s on the server. OJS 2.4.6 should have scheduledTaskLogs, like your test install.

It seems you already had the stats processing working (see the number of archived files), and suddenly it stopped working. I still bet it’s a folder permission problem. Can you make sure to check the owner of the files_dir folder and also the owner of each folder inside usageStats? The user must be the same that is running the PHP process.