Usage Statistics plugin - usage events logs are not processed into the 'metrics' table

Description of issue or problem I’m having:
In the journal’s dashboard the articles statistics are not showing up and they never did. Investigating the issue I found out that the activity is being tracked, there is a log file for every day since the journal instance was created and in 'scheduled_tasks" table the ‘last_run’ for ‘plugins.generic.usageStats.UsageStatsLoader’ is updated everyday, but the ‘metrics’ table is completely empty. Moreover, there is no log file for the Usage Statistics plugin in the ‘scheduledTaskLogs’ directory. All the logs remain in the ‘usageEventLogs’ directory while all the other directories in ‘usageStats’ are empty.

Steps I took leading up to the issue:
Nothing in particular, the statistics were not updating from the start. Perhaps it’s relevant that OJS was installed using Softaculous provided by the hosting platform, however, almost everything else works just fine.

What I tried to resolve the issue:
First of all, I tried to manually move one of the log files from ‘usageEventLogs’ to ‘stage’, but nothing happened the next time the task allegedly run (‘last_run’ in ‘scheduled_tasks’ was updated). Next I tried to manually schedule a cron job using CRON scheduler provided by the host platform with the following command

php /ojs/tools/runScheduledTasks.php /ojs/plugins/generic/usageStats/scheduledTasks.xml

However, I was unable to run the task. When thrying to run the task the output I received was

Standard program output:
Tasks file “/ojs/plugins/generic/usageStats/scheduledTasks.xml” does not exist or is not readable!
No data on program’s error output.

At first I thought the provided path was incorrect, but I tried every possible way to phrase the path to the plugin’s sheculled task xml and the result was the same, so I was inclined to think the problem is readability of the file, but the same things happends when I try to use ‘/ojs/plugins/importexport/doaj/scheduledTasks.xml’ which should be working, since every day when doaj plugin’s task runs it creates a log file in ‘scheduledTaskLogs’ directory. At this point I no longer have a clue what exactly is the issue.

Application Version - e.g., OJS 3.1.2:

Additional information, such as screenshots and error log messages if applicable:

Before adding the task to the cron you need to be sure the command works as expected.

If running the command…

php /ojs/tools/runScheduledTasks.php /ojs/plugins/generic/usageStats/scheduledTasks.xml

Tells you the path is wrong the problem is the path, not permissions.
Did you try to “ls /ojs/plugins/generic/usageStats/scheduledTasks.xml” ?

It’s an strange path: Are you sure your ojs is at root level?
On debian-like, OJS is usually installed at “/var/www/html”…

Please, go to the specified folder (/ojs/plugins/generic/usageStats) and run a “pwd” to confirm.
Confirm the file “scheduledTAsks.xml” file is also there.

The only thing I can imagine you are in a hosting service that hides the real path and cron and scripts don’t take the virtual one.