Upgrade ojs.3.2.1 Request Timeout

I have problem
I success upgrade ojs 2.4.8 to 3.0.0.
But Now i want to upgrade to ojs.3.2.1

Error Request Time out after 3…4.Minute
I set Max_excution_time in php to 0 and then 16000
But still error in upgrade

Can anyone help me ?
Thank you

In config file set driver mysqli
Check phpinfo and set max_excution_time 16000

Can anyone help me ?

what version of php did you use when upgrading 3.0 to 3.2? Have you tried upgrading using php version 7.2?


Solved …
In local upgrade and
Then backup From Local and Restore in Host .

Now 1 problem :
when i click old pdf link ; white page shows and Article Not show …HyperLink is correct …

I see in old db Article Table exist But after Upgrade Article table (and start table Name With Article) not exist !!! Import them Manually …
But Not Work
Pdf Article is not show .!!
Both of them
in local and Host Not work

Why ??

Hi @Hrm333,

Check your files_dir in config.inc.php and make sure the contents of that directory got moved to the new server with appropriate file permissions.

Alec Smecher
Public Knowledge Project Team

in config.inc.php : files_dir = /home/researc6/public_html/********.org/files
Permisson : 0775
Yes Files Folder Exist in The Location

I uploaded New Pdf File With Ojs Admin Panel And See Correct Located in


and it Work and open …But Old Pdf Not open

Hi @Hrm333,

Is your files_dir inside your public_html? It’s not safe to put it there, unless you’ve protected it from direct access using e.g. a .htaccess file. See the “Recommended Configuration” section of docs/README.md for details.

Alec Smecher
Public Knowledge Project Team

I Downloaded Files In local and Problem Solved

then Backup From Local And Restore To host
But Old Pdf Still Not Open

very Warning In Error Log Host:
home/researc6/public_html/jour****.org/files/journals/5//articles/31/". Skipping this file.

Hi @Hrm333,

If the PDFs are working on your local machine, but not on your server, then the problem must be either your files_dir in config.inc.php pointing to the wrong place, or file permissions on your server being incorrect.

However, I urge you to consider my note above. If you do not resolve this, your installation is unsafe and you’re likely to be hacked.

Alec Smecher
Public Knowledge Project Team