Upgrade 2.4.8 to 3.0 failed


I’m getting an error when upgrading to 3.0

ERROR: Upgrade failed: DB: Duplicate entry ‘18398-3-1’ for key ‘review_rounds_submission_id_stage_id_round_pkey’

which is the same error seen at the bottom of the thread here:

I have tried dropping the index before the upgrade but the upgrade script just re-creates it.
I have also tried deleted the record 18398 but another record has the same problem so I’d just end up deleting a lot of records.

Here is the debug info in case that helps:

Duplicate entry ‘18398-3-1’ for key ‘review_rounds_submission_id_stage_id_round_pkey’
ADOConnection._Execute(UPDATE review_rounds SET stage_id=3, false)% line 1051, file: /var/www/sites/ojs3-sandbox/eblip/lib/pkp/lib/adodb/adodb.inc.php
ADOConnection.Execute(UPDATE review_rounds SET stage_id=3)% line 440, fi le: /var/www/sites/ojs3-sandbox/eblip/lib/pkp/classes/install/Installer.inc.php
Installer.executeSQL(UPDATE review_rounds SET stage_id=3)% line 435, file: /var/ www/sites/ojs3-sandbox/eblip/lib/pkp/classes/install/Installer.inc.php
Installer.executeSQL(Array[103])% line 396, file: /var/www/sites/ojs3-sandbox/eblip/lib/ pkp/classes/install/Installer.inc.php
Installer.executeAction(Array[3])% line 265, file: /var/www/sites/ojs3-sandbox/eblip/lib/pkp/cla sses/install/Installer.inc.php

Hi @jhennig,

See this issue.

Alec Smecher
Public Knowledge Project Team

Thanks Alec. I deleted all the duplicates and it now worked.

The stage_id was null for al the duplicates which therefore won’t trigger the review_rounds_submission_id_stage_id_round_pkey unqiue index, which is why these duplicates exist in the first place.

Hi @jhennig,

Thanks for following up, and glad to hear it’s working. This does seem to be a data error in the OJS 2.x installation, but I’m still not sure where these duplicates are coming from; if you do have any insight into that, please let me know!

Alec Smecher
Public Knowledge Project Team

1 Like