Unable to upgrade from to

Description of issue or problem I’m having:
I am unable to do a full package update from to
it leaves me on a blank page

Steps I took leading up to the issue:

What I tried to resolve the issue:
I double checked all folders have right permissions and tried to copy the folder again.

Application Version - e.g., OJS 3.1.2:

Additional information, such as screenshots and error log messages if applicable:
When I eneble all debug info, I get the following:

Notice: Trying to access array offset on value of type bool in /var/www/virtual/entecho/ojs/lib/pkp/classes/install/Installer.inc.php on line 742 Fatal error: Uncaught Error: Call to a member function getCurrent() on null in /var/www/virtual/entecho/ojs/lib/pkp/classes/site/VersionDAO.inc.php:103 Stack trace: #0 /var/www/virtual/entecho/ojs/lib/pkp/classes/install/Installer.inc.php(755): VersionDAO->insertVersion() #1 /var/www/virtual/entecho/ojs/lib/pkp/classes/install/Installer.inc.php(444): Installer->addPluginVersions() #2 /var/www/virtual/entecho/ojs/lib/pkp/classes/install/Installer.inc.php(251): Installer->executeAction() #3 /var/www/virtual/entecho/ojs/lib/pkp/classes/install/Installer.inc.php(174): Installer->executeInstaller() #4 /var/www/virtual/entecho/ojs/lib/pkp/classes/install/form/UpgradeForm.inc.php(43): Installer->execute() #5 /var/www/virtual/entecho/ojs/lib/pkp/pages/install/InstallHandler.inc.php(130): UpgradeForm->execute() #6 /var/www/virtual/entecho/ojs/lib/pkp/classes/core/PKPRouter.inc.php(395): InstallHandler->installUpgrade() #7 /var/www/virtual/entecho/ojs/lib/pkp/classes/core/PKPPageRouter.inc.php(246): PKPRouter->_authorizeInitializeA in /var/www/virtual/entecho/ojs/lib/pkp/classes/site/VersionDAO.inc.php on line 103

I think your files are missing something.
How do you upload the new version to the web?
Are you uploading the files one by one by ftp or as a zip file?

thank you for pointing in the right direction. I copy it via FTP, since I can not unzip at server (no ssh rights)
I have copied it once again, and now it works
thank you

1 Like