Unable to upgrade due to php version

It seems we cannot upgrade to the latest version of OJS, because it requires a higher php version. We are using Softaculous, and when trying to upgrade, the error says “Required php version 7.1 or higher”. We have 7.0 version. Is it possible that the latest OJS requires 7.1 version? I asked my hosting provider for help, and they said we need to pay a lot more money in order to get 7.1.

Hi @filipi,

You can check our release requirements in docs/README (or docs/README.md) in each release. OJS 3.1.2-x requires PHP 7.1 or newer.

It’s up to your host how they manage their servers, but PHP 7.0 is beyond end-of-life and no longer supported by the PHP development team. Service providers should generally not be running it anymore. See https://www.php.net/supported-versions.php for details.

Regards,
Alec Smecher
Public Knowledge Project Team

Many thanks, I alerted my hosting provider. They said an upgrade will follow soon.