Unable to edit already submitted article/ Archived Summisions/workflow not working


#1

I want to edit metadata of already published articles, when I click Submissions>Archives and click the Published link of an article to edit it it takes me to url http://mysite.com/index.php/myjournal/workflow/index/4/5

But nothing happens, only blank page is displayed

OJS ver : 3.0.2.0
OS platform|WINNT
PHP version|5.6.30|
Apache version|Microsoft-IIS/7.5|
Database driver|mysql|
Database server version|5.7.18-log|

Developer tools displays following error

GET http://mysite.com/lib/pkp/fonts/fontawesome/fontawesome-webfont.woff2?v=4.3.0 404 (Not Found)

Handler.js:38 Uncaught Error: The handler “$.pkp.controllers.linkAction.LinkActionHandler” has already been bound to the selected element!
at proxyConstructor.$.pkp.classes.Handler (Handler.js:38)
at proxyConstructor.$.pkp.classes.ObjectProxy.parent (ObjectProxy.js:112)
at proxyConstructor.$.pkp.controllers.linkAction.LinkActionHandler [as constructor] (LinkActionHandler.js:43)
at proxyConstructor.$.pkp.classes.ObjectProxy.parent (ObjectProxy.js:112)
at new proxyConstructor (Helper.js:283)
at Function.$.pkp.classes.Helper.objectFactory (Helper.js:209)
at HTMLAnchorElement. (jquery.pkp.js:37)
at Function.each (jquery.min.js:2)
at n.fn.init.each (jquery.min.js:2)
at n.fn.init.$.fn.pkpHandler (jquery.pkp.js:31)
5:1 GET http://mysite.com/lib/pkp/fonts/fontawesome/fontawesome-webfont.woff?v=4.3.0 404 (Not Found)

Please help…


#2

Hi @sharad7703,

Before digging into this in detail, I would strongly suggest upgrading your OJS – version 3.0.2 is quite old.

Regards,
Alec Smecher
Public Knowledge Project Team


#3

hi @asmecher

I have successfully updated to version 3.1.1.1 (June 12, 2018 - 03:35 PM)

I am still facing two issues,

  1. problem in deleting articles from newly appearing incomplete submissions list pane

.
.

.
2. Editing already submitted article

After clicking View Submission button, following error occurs.

I have tried clearing the browser cache and even flushing out OJS cache manually from server but doesn’t works.

If I open the same in an Incognito window, and after multiple hard refresh the same link with Ctrl+F5, the page opens.

I tried to search for the errors and solution in OJS forum, but could not get any clue from there.

I am using QuckSubmit plugin to add articles to OJS.

With regards,
Sharad