Unable to assign a DOI to an article already published

Description of issue or problem I’m having:
An editor has published an issue on 9-15-2021. There were a few articles that she did not assign a DOI and published it without a DOI. Now she wants to add a DOI to those articles, but the interface will not allow it.

It says “This version has been published and cannot be edited”.

What I tried to resolve the issue:

I have tried to fix it by unpublishing the article and I get a message that says it needs to be assigned to an issue in order to assign a DOI. When I assign it to the issue, it still will not allow me to add the DOI. Do I need to create a new version? It’s not really a different version of the article so that is not ideal at all.

Application Version - e.g., OJS 3.1.2:


Additional information, such as screenshots and error log messages if applicable:

Dear @Janet_Swatscheno ,

assigning DOI is very easy in the unpublishing version. Did you try it as a Journal Manager or? Which role you have? Could you take a picture of your problem? Make picture with DOI of how you enter in it. In the fact, this is not a problem. You made some minor mistake.


Hi @Janet_Swatscheno ,

it might be that last versions of the OJS don’t allow changing already published articles ‘on the fly’. You have to create a new version of the article.

Regards, Primož

I did find a solution to this problem, although it’s far from ideal. I had to make the DOI assignment manual (instead of the normal pattern of volume, issue, article number) in the DOI plugin. Then it allowed me to unpublish the article and type in the DOI I wanted to use and re-publish it.

I really did not want to create a new version because the articles themselves were not different.

This topic was automatically closed after 4 days. New replies are no longer allowed.