Theme - Typography not working in OJS 3

Under Website Settings - Appearance you can choose among different kinds of Typography if you choose the Default Theme, but it does not seem to work properly. The UI doesn’t change when a new type settings is chosen.
Niels Erik

1 Like

Hi @nef

Can you specify OJS version that you are using as well as confirm that you have cleared the template cache (through admin dashboard) and browser’s cache after applying this option?

We use version I use the Ctrl+F5 to reload the page. Isn’t it okay?

I don’t remember actually if it is needed here, but try Administration -> Clear Template Cache

Sorry, it doesn’t help


I would like to warm up this thread. Cleared caches are not helping, too.
We have OJS

Thank you in advance,

We are also seeing this issue on OJS 3.2.1. Template Cache clearing doesn’t help.

@nef, @Vitaliy and @unkej. I believe I figured out what the issue is. Looking at the code shows that it won’t make the changes if the “enable_cdn” option isn’t enabled. So to get it to work you need to:

  1. Edit and change enable_cdn = Off to enable_cdn = On.
  2. Go to the theme and select your font and click save. This is important because I believe the change will only occur after you click the save button.

I am unsure if you still need an answer after all this time but if you do I hope it helps! This is what worked for me!

1 Like

Thank you.
It seems that the problem has been solved in OJS
Niels Erik

Thank you very much! This helped a lot! Now I hope that no side effects occur. :smiley:

No worries! I haven’t done an extensive search, but what I’ve found so far is that when enabled it will load fonts, fontawesome and jQuery from a CDN instead of serving it locally.