The theme healthSciences-1.0.4 does not work in version 3.1.2-1

Hello, I’m trying to install healthSciences-1.0.4 in OJS 3.1.2-1 but it’s not getting it. I can not install a plugin because / tar is not configured, I do not know what this is.
I try to install manually, but some blocks look incorrect. The theme is for version 3.1.2, at this time is 3.1.2-1, how can I find the previous version of OPJ?
Or solve the problem with the theme in the new version.

Hi @Iulian,

Can you explain how you are trying to install the theme?

Yes,
The downloaded file healthSciences-1.0.4.tar.gz unzip it in the “http: //…/plugins/themes/” directory then in the administration panel at OJS Settings -> Website -> Plugin.
After, Settings -> Website -> Theme (activate the new interface, but it does not appear in the list here).
I tried to delete the original theme and I just leave it on this new one, it starts, but some blocks look with errors, instead of information displays the variables in the code.

Do you have any error message in PHP logs when using the updated version?
Have you cleared the template cache via the Administration Dashboard? As far as I remember it should be done automatically when changing a theme but just in case.
Have you cleared the browser cache if page isn’t shown correctly?

yes, there are many errors after installing the system. I mention that 3.1.2-1 was installed without being updated because it is the latest version.
We have encountered a problem translating the pages, the language we want to set is not in the list. How can we manually translate?

Can you specify the problems in more details? Particularly:

Note, the theme works perfectly with OJS 3.1.2-1 on my test instance, so I can’t reproduce any problems. In order to fix, can you describe steps to reproduce them?

I have read in various documentation that after the manual installation the given code has to be executed:

  • From your application’s installation directory, run the upgrade script:
    $ php tools/upgrade.php upgrade
    (NOTE: It is recommended to back up your database first.)
  • Enable the plugin by going to:
    Management > Website Settings > Plugins >

Probably this is the problem, but OJS is installed on the host and not on the server and we do not have access to the terminal. How else could we do that?

This script starts a database and files folder upgrade. To install the Health Sciences theme you don’t need to run that script, although some plugins may require it.

Just unpack and copy the latest version of the theme to the plugins/themes/healthSciences directory. Or install through plugin gallery if your server supports untar operation.

The problem has been solved, I created a video on youtube with every step.
The theme started working after I commanded the “$ php tools / upgrade.php upgrade” command.
It is only valid for the server, hosting is not access to the terminal.

That’s strange, the theme should work without database upgrade. So, all steps that you’ve done are right, except running the script. Have you tried without it? What problems have you encountered?

Without updating the database, the theme did not appear in the admin.
How can I remove the problem? For English, it’s ok and for other languages not

Yeah, that’s a missing translation for Russian locale. By default, it’s not available. Localization files can be found inside locale folder of the plugin. You can add Russian translation there or use Translator plugin. If you will work with locale files, let me know if encounter any problems. Also, I would be appreciated for contribution.

We will translate the theme for 2 languages, Russian and Romanian, but with the translated plugin we have the same problems, it works locally, but don’t working in hosting.
If we get full support we will add the translation to this forum.

I contributed with the translation locale folder Romanian and Rusian.
We would like to translate OJS in Romanian but the translate plugin does not work, how can we proceed?

Hi, Julian can you help me pleas, Hello, I am trying to install the Healt theme and when I update it, it tells me that I must load a .tar.gz file, which I download, but when I load, I get an error that the folder does not have that file. I contacted the person in charge of the server and unzipped the file but now it gives this error, can you help me what am I doing wrong?

hi i do this, but not fixed, please help me

Cross-posted: HealthScience theme: Impossibility to install

(@Yra_Rojas, it’s best not to post the same content in multiple places – it clutters the forum.)

Regards,
Alec Smecher
Public Knowledge Project Team