The requested URL is not recognized

Hello, I have a problem when saving the Zenodo DOI. In the publication tab, and input the DOI in the identifiers, I cannot save it. When I click save, there is an error “The requested URL was not recognized”

We are using OJS 3.3 and PHP 7.4

Here is the screenshot
request URL was not recognized

This is the error in the log:
[19-Jun-2021 12:42:46 UTC] ojs2: 404 Not Found

Hi @moisesneil,

I don’t think you can use the zenodo prefix like this. You need to use a proper doi prefix with numbers - did you you get provided anything like this?

PKP Team

Hi @rcgillis here is the updated screenshot using the prefix that begins with 10.5281. Yes, this the format of the DOI I got from Zenodo. but the problem on the “The requested URL was not recognized” still persist.

the requested URL was not recognized

This Zenodo DOI actually works with the demo version of OJS. I tried replicating this in OJS3 Testdrive Journal and the Zenodo DOI works fine. I can save it. Please see screenshot below. It works with the demo version of OJS but not with our journal.


Hi @moisesneil,

Hmmm… I’m not entirely sure what is going on here. Do you have your plugin settings configured correctly? Website > Plugins > DOI Plugin (under the section “public identifier plugins”).

PKP Team

I think the configuration of the DOI is fine. I hope I configured it correctly. Please see screenshot. With this configuration, the problem “The requested URL was not recognized” is still there and I cannot use/save our Zenodo DOI.

Screen Shot 2021-06-25 at 07.34.28

Hi @moisesneil,

Hmmm… I’m unsure of what to try next, but I’m wondering if @bozana, might be able to look at this and see what she could suggest.


Hi @moisesneil

Hmmm… It seems that something is wrong with your URLs i.e. that our internal API endpoint/URL that is used to save that form is not found. The internal API endpoint/URL used to save that form is /api/v1/submissions//publications/.
Thus, could you check if this API URL functions: /api/v1/submissions ?
Have you maybe made any redirects or changes or restrictions in the original OJS URL paths?
I wonder how other API URLs function, e.g. a submission and publishing? :thinking:


Hi @bozana thank you very much. We will check into this, hopefully, this will solve our issue. As to submission, we have no problem. For publishing, so far we have used the QuickSubmit plug-in and it worked fine.