Text in text fields in Journal, Website settings is not saving anymore OJS 3 on Debian + PHP7.2, Apache + oldGregg theme


I have two installations of OJS, on a Debian 9.8 (stretch) , PHP 7.2.17-1, MariaDB 10.1.37, and the oldGregg theme release

Everything went OK, till this week, when if I try to change the text in the text fields in Journal, or Website settings as an administrator, I hit the Save button, I get the notification the page was saved, but the text field does not change! The problem seems to be for text fields, but not for radio buttons, or check-boxes.

But there is no problem in saving text in article Metadata, for example …

Since I didn’t touch the OJS installation in months, I think it is due to something from the system (PHP - maybe? or Apache?) that might updated automatically - I think …

I tried to disable mod_security - but no positive result.
In the Apache error log there is nothing useful (with or without display errors, show stack trace on)
The javaScript console doesn’t show anything

Any idea would be appreciated.

Hi @ojspkpuser,

Check the file permissions in your cache directory to make sure that OJS can modify the files there. Also look further into your PHP error log – nothing in the screenshot looks relevant, but there might be something else in there that is.

Alec Smecher
Public Knowledge Project Team

Thank you @asmecher, I rechecked the permissions, they were ok, cache, public writable, ownership for apache daemon.

There were no other things in the log from my IP (I grep-ed from the log file based on my IP).

Best regards,


@asmecher now it works, I don’t know how, … I did not modify anything, I restarted the php.fpm service (maybe that was the problem …) very strange…

Thank you so much for all the help you always give!!!

Best regards!


1 Like