Submitting articles from China (OJS

Since we upgraded from 2.4.8 to about two months ago, we have had at least six instances where an author in (mainland) China was unable to submit a paper.

The usual behaviour is that when they click New Submission, nothing happens except an everlasting progress indicator. In one case I helped an author through Step 1 of the submission process, but they were unable to continue to Step 2. One author tried from multiple computers with the same result.

This has only occurred from China. However, people in China can read the journal contents just fine.

I could never find anything useful in the server/php logs, but I might have missed it. My best guess is that the Chinese firewall is blocking something essential such as We know that China regularly blocks multiple Google products. I don’t have a good suggestion.

This stackoverflow thread might be relevant. Or might not.

Hi @bdm,

You could try turning off the CDN option in If you’re using ReCAPTCHA, see also reCaptcha not working from China · Issue #2993 · pkp/pkp-lib · GitHub.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher, I’m not sure exactly what enable_cdn does. Can I just turn it off without downloading anything onto my local server? We use mathjax via as well as the stuff. Brendan.

Hi @asmecher,

The problem is definitely caused by being blocked in China. Tests by friends over there found that it depends on the browser, the network, the time of day, without consistency.

I have set enable_cdn=Off and two Chinese authors who could not submit papers before can now do so successfully.

I guess this means we can’t use the fonts like toto that are also served from The mathjax plugin ignores enable_cdn (which is good).