Submission Wizard Radio Button Missing & E-mail do not send

Description of issue or problem I’m having:
The radio button in the agreement to data collection and storage option does not appear. It is clickable, but it is not visible. How can I fix this?

Another issue I am having is that when testing the submission section, I get an error message that an e-mail couldn’t be send - so I would like to fix that too.

Steps I took leading up to the issue:
I just used the regular installation.

What I tried to resolve the issue:
I don’t know what to do.

Application Version - e.g., OJS 3.1.2:

Additional information, such as screenshots and error log messages if applicable:

Hi @abenteuerzeit,

By chance are you using the Firefox addon described here: No checkbox for privacy statements on submission, reviewer request, etc. Error only occurs with Firefox browser; Chrome works [OJS]] - #2 by rcgillis

That has caused people issues with this field previously.

PKP Team

No, Google Chrome.
What I did was I changed the settings in from Off to On - so it removed that field altogether.

; Set this to "On" if you would like to only have a single, site-wide Privacy
; Statement, rather than a separate Privacy Statement for each journal. Setting
; this to "Off" will allow you to enter a site-wide Privacy Statement as well
; as separate Privacy Statements for each journal.
sitewide_privacy_statement = On

All I am trying to solve now is, “There was a problem sending an email message. Please try again later, or contact your system administrator”.

Hi @abenteuerzeit,

Hmm… I’m not sure what could be going on in this case. I will see if one of my colleagues can assist when they are able to/available.

PKP Team

I figured out the e-mail - I changed from gmail to microsoft and it works.

1 Like

This topic was automatically closed after 4 days. New replies are no longer allowed.